Closed Bug 972879 Opened 6 years ago Closed 6 years ago

crash in java.lang.NoSuchMethodError: android.widget.RelativeLayout.setSystemUiVisibility at org.mozilla.gecko.GeckoApp$32.run(GeckoApp.java)

Categories

(Firefox for Android :: General, defect, critical)

30 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
fennec 29+ ---

People

(Reporter: aaronmt, Assigned: jdover)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-83d664a8-3591-4491-917b-1db092140213.
=============================================================

java.lang.NoSuchMethodError: android.widget.RelativeLayout.setSystemUiVisibility
	at org.mozilla.gecko.GeckoApp$32.run(GeckoApp.java:2802)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:130)
	at android.app.ActivityThread.main(ActivityThread.java:3691)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:912)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:670)
	at dalvik.system.NativeStart.main(Native Method)

Specific to Android 2.3; seems to affect the Kindle, original Desire and an Ace 2
Josh, seems like a regression from bug 960159. Could you have a look?
Assignee: nobody → jdover
tracking-fennec: --- → ?
Keywords: regression
Flags: needinfo?(jdover)
Added check to make sure we don't call this on SDK < 14
Attachment #8377652 - Flags: review?(lucasr.at.mozilla)
Flags: needinfo?(jdover)
Comment on attachment 8377652 [details] [diff] [review]
Only dim system UI on SDK >= 14

Review of attachment 8377652 [details] [diff] [review]:
-----------------------------------------------------------------

Yep. Is this Aurora too? Make sure you request uplift if it is.
Attachment #8377652 - Flags: review?(lucasr.at.mozilla) → review+
Yes, how do I do that?
Comment on attachment 8377652 [details] [diff] [review]
Only dim system UI on SDK >= 14

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:
Attachment #8377652 - Flags: approval-mozilla-aurora?
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 160159
User impact if declined: Crashes in Reader Mode on anything below ICS due to unsupported system flag
Testing completed (on m-c, etc.): n/a
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/43e07016a5bb
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Attachment #8377652 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
tracking-fennec: ? → 29+
You need to log in before you can comment on or make changes to this bug.