Don't do test log coalescing for single-test runs

RESOLVED FIXED in mozilla30

Status

Testing
Mochitest
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Bobby Holley (parental leave - send mail for anything urgent), Assigned: froydnj)

Tracking

unspecified
mozilla30
x86
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When I'm developing a test, I like to see the TEST-PASS output to make sure that I'm running the tests I expect.

In this scenario, I'm basically always doing |mach mochitest-foo some_test.foo|, rather than a directory-wide or system-wide run. In this case, it doesn't seem like there's much benefit from the log-coalescing, and so I think we should turn it off by default.

The verbose option suggested in bug 969437 is nice, but it's less discoverable, and it's always nice to do something smart by default to ease the new-contributor experience.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 969437
Status: RESOLVED → REOPENED
Depends on: 969437
Resolution: DUPLICATE → ---
Created attachment 8381487 [details] [diff] [review]
always output log messages for a single mochitest run

This is the same patch you looked at in bug 969437; you may want to look at my
feedback in https://bugzilla.mozilla.org/show_bug.cgi?id=969437#c6 to your
previous comments.
Attachment #8381487 - Flags: review?(jmaher)
Attachment #8381487 - Flags: review?(jmaher) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/b7ca08373ee9
Flags: in-testsuite-
Assignee: nobody → nfroyd
https://hg.mozilla.org/mozilla-central/rev/b7ca08373ee9
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.