Stitched (Dashed) Rounded Borders Do Not Render Correctly

RESOLVED DUPLICATE of bug 382721

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 382721
3 years ago
2 years ago

People

(Reporter: Aaron Staker, Unassigned)

Tracking

27 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8376461 [details]
screenshots.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

Use the code from here:  http://css-tricks.com/snippets/css/stitched-look/

Change all border-radius properties to 50%.  


Actual results:

The output instead of showing a dashed line, will only show a solid border.  I'm using this on a relatively small image.  


Expected results:

When the border is rendered it should be dashed rather than solid.  I have attached several screen shots.  Showing behavior in Chrome (original dashed), Chrome (border radius in %) and Firefox behavior in %.
Hi Aron,

I have managed to reproduce the issue using latest Firefox release (43.0.4) and latest Nightly build (46.0a1). After I changed the border-radius to 50 px the border dots are united on edges. 

Firefox: 43.0.4, Build ID: 20160105164030, User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Firefox: 46.0a1, Build ID: 20160107030235, User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

Considering this, I will mark this as NEW and assign a component to it. If someone considers that the component is not the right one, please feel free to change it with a more appropriate one.

Thanks, 
Cosmin.
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: View Rendering
Ever confirmed: true
Product: Firefox → Core
Please at least do a search for duplicates?  "dashed border radius" finds the original pretty easily...
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382721
You need to log in before you can comment on or make changes to this bug.