Closed Bug 973206 Opened 8 years ago Closed 8 years ago

Unable to close a window by clicking on the red square at an item out of taskbar

Categories

(SeaMonkey :: Tabbed Browser, defect)

SeaMonkey 2.24 Branch
x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 921874

People

(Reporter: tit_pom, Unassigned)

Details

Attachments

(1 file)

Attached image Steps-and-Results.jpg
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0 SeaMonkey/2.24 (Beta/Release)
Build ID: 20140203230027

Steps to reproduce:

Don't use tabs, only windows ....
Refer to the attached picture Top part:
Step 1 is put your mouse over point 1.
Step 2 is put your mouse over point 2.
Step 3 CLICK on the red square at point 3. 


Actual results:

Refer to the attached picture - Bottom part:
The clicked window should be closed.



Expected results:

Refer to the attached picture - Middle part:
The clicked window is not closed - it' still there just the content and the title vanished. the window is now a BLANK one.
Sorry, i mismatched my explanation about the part of the joined picture -  you should read:
Steps to reproduce:

Don't use tabs, only windows ....
Refer to the attached picture Top part:
Step 1 is put your mouse over point 1.
Step 2 is put your mouse over point 2.
Step 3 CLICK on the red square at point 3. 


Actual results:

Refer to the attached picture - Middle part:
The clicked window is not closed - it' still there just the content and the title vanished. The window is now a BLANK one.



Expected results:

Refer to the attached picture - Bottom part:
The clicked window is closed.
Windows 7 Home Premium (x64)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 SeaMonkey/2.24

I have three windows open, one of which has this bug report.  I have no tabs open.  

1.  I position my cursor over the taskbar item for this window and see a list of all three with the X in an orange box for this window.  

2.  I move my cursor onto that list but over a different entry in the list.  The X in the orange box noted in step #1 disappears, and a new X in an orange box appears for the entry under my cursor.  

3.  I select the X.  The associated window CLOSES.  It is NOT blank; it is gone.  

In step #2, if I move my cursor onto the list over the entry for the same window that it was over in the taskbar and then do step #3, the results are the same as for step #3.  

I have done some extensive tweaks to Windows 7, which might explain the difference between what I experience and what this bug report describes.
What i can add, is that for the step 3, instead of clicking on the red-square, i rigth-click in the bar, and i choice "Close" - i have the same result, the window is not closed, but it is now a blank window.
Now, with SM 2.4 if a want to close a specific windows, i am obliged to open it, and/or give it the focus then i can close it.
In the past, step 3 of the top part of the picture, closed the window nicely.
Raymond, try the following:
1. Browse to about:config (and if warned that this could void your warranty, click the button saying that you'll be careful).
2. type "lasttab" (without the quotes) in the Filter box. You should see a line for the preference browser.tabs.closeWindowWithLastTab
-- The default for that preference is, or used to be, true, meaning the behaviour that D.E.Ross describes in comment #2.
3. If the setting on your browser is false instead, double-click the line to toggle it.
4. Try your "Steps To Reproduce" and tell us what happens.
5. At next browser startup, check this preference again to check that it is still set to true. If it isn't, then maybe there is a user.js in your profile which sets it the wrong way at browser startup.

Note that any open window still has at least one open tab in it. "Not closing the window when the last tab is closed" actually means that if a user asks to close a tab, and it is the last tab, that tab will not be closed but pointed to about:blank (the empty page) instead.
Component: General → Tabbed Browser
Changing browser.tabs.closeWindowWithLastTab option was interesting - but:
browser.tabs.closeWindowWithLastTab by default is true.
With a false or a true, i am not able to close the window. (i don't have a user.js)
Hm. I'm out of ideas then. If anyone else (especially on Windows like the reporter) has an idea of what could make a difference, feel free to comment.
I tried reproducing the results indicated in comment #3.  I right-clicked on the SeaMonkey button in my taskbar and then selected the X in the orange box.  The SeaMonkey window that was on top closed; it did not remain open and blank.  

As I indicated before, I have done some major tweaks to Windows 7, which might account for the differences between what Raymond and I experience.  No, I will not revert to a "vanilla" Windows 7 to test this.  I have had Windows 7 for about four months and am still trying to get it configured that way I want it.
Yes, I tried a clean, new profile.  The problem does not exist there.  

Now my problem is that I do not know how to isolate what in my existing profile causes this problem.  I started to create a new profile that would include all my old E-mail, newsgroup, and RSS messages.  That proved too daunting.  I will go to the mozilla.support.thunderbird newsgroup to see if someone can help me.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
Oops!!  I closed the wrong bug report.  Ignore my comment #8.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(In reply to David E. Ross from comment #7)
> I tried reproducing the results indicated in comment #3.  I right-clicked on
> the SeaMonkey button in my taskbar and then selected the X in the orange
> box.  The SeaMonkey window that was on top closed; it did not remain open
> and blank.  
> 
> As I indicated before, I have done some major tweaks to Windows 7, which
> might account for the differences between what Raymond and I experience. 
> No, I will not revert to a "vanilla" Windows 7 to test this.  I have had
> Windows 7 for about four months and am still trying to get it configured
> that way I want it.

Did you say that NOW to use SM correctly as before (in 2.17) we should tweak Windows7 ?
Are you the only one that try to test if this problem can be confirmed ?
It's really annoying the fact that i cannot close a specific SM window so easily as before.
Re comment #10:

> Did you say that NOW to use SM correctly as before (in 2.17) we should tweak
> Windows7 ?


No.  I tweaked Windows 7 because there were features I frequently used in Windows XP that are not inherent in Windows 7.  This had nothing to do with SeaMonkey or any other Mozilla-based application.
Did you have an idea about the tweak that correct this bug ?

Or should a agree that this bug will grow my list of bugs i posted (none of them has been corrected yet :-(
Exalm suggest me this:
Try setting browser.taskbar.previews.enable in about:config to false. 

That did the trick - but normally we could work with browser.taskbar.previews.enable TRUE.
This is just a workaround ... the BUG is still present.
> This is just a workaround ... the BUG is still present.
1. Does this bug also manifest on Firefox 27?
2. Mcsmurf probably knows more about this than I do. I'll put him on the CC list.
Yes, it's a bug.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 921874
You need to log in before you can comment on or make changes to this bug.