Toolbarbutton [type"menu"] dropmarkers are not displayed correctly in the menu panel

RESOLVED DUPLICATE of bug 971246

Status

()

defect
RESOLVED DUPLICATE of bug 971246
6 years ago
6 years ago

People

(Reporter: davinc57, Unassigned)

Tracking

(Blocks 1 bug, {regression})

30 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 attachments)

Posted image menu1.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140212131424

Steps to reproduce:

Firefox 30.0a1 build 20140215030204

Add-ons like Adblock Plus, All in one sidebar are not displayed correctly in the menu panel. They use toolbarbutton[type"menu"] : the dropmarker is cut and the padding & margin are not correct compared to the other icons displayed in the menu panel. See attached files.
Posted image menu2.png
Component: Untriaged → Theme
In a 2014-02-15 nightly on OS X I can confirm wrong paddings, this is something I overlooked but this issue was apparently present from the very start. As to the detached dropmarker, this seems to be a recent regression - it wasn't present in the 2014-02-02 nightly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Calling this P3 to investigate, but if it's just "Adblock is doing one of the million things that could break this kind of button", we should untrack it (ie, if it's not a general problem we should fix in Australis).

If this actually regressed between 2/2 and 2/15, it would be good to track down what did it.
Blocks: 940307
Whiteboard: [Australis:P3]
Blocks: 960258
The opener mentions to All in one sidebar too, and I can see it with my add-on Simple Locale Switcher in Linux Nightly. It isn't specific to ABP.
(In reply to Carlos [:nohamelin] from comment #4)
> The opener mentions to All in one sidebar too, and I can see it with my
> add-on Simple Locale Switcher in Linux Nightly. It isn't specific to ABP.

Can you track down a regression window (e.g. with mozregression) ?
Flags: needinfo?(nohamelin)
(In reply to :Gijs Kruitbosch from comment #5)
> (In reply to Carlos [:nohamelin] from comment #4)
> > The opener mentions to All in one sidebar too, and I can see it with my
> > add-on Simple Locale Switcher in Linux Nightly. It isn't specific to ABP.
> 
> Can you track down a regression window (e.g. with mozregression) ?

Last good revision: 1e9f169c9715 (2014-02-06)
First bad revision: dedf12c4e805 (2014-02-07)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1e9f169c9715&tochange=dedf12c4e805


Probably related to:
https://bugzilla.mozilla.org/show_bug.cgi?id=897496
Flags: needinfo?(nohamelin)
Summary: Toolbarbutton [type"menu"] are not displayed correctly in the menu panel → Toolbarbutton [type"menu"] dropmarkers are not displayed correctly in the menu panel
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 971246
You need to log in before you can comment on or make changes to this bug.