Closed Bug 973244 Opened 6 years ago Closed 3 years ago

Firefox hangs after startup if LastPass addon installed

Categories

(Firefox for Android :: General, defect)

27 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: martin.mcdowell, Unassigned)

Details

(Keywords: addon-compat, hang, perf, Whiteboard: [workaround: install https://lastpass.com/lp.xpi])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140130123732

Steps to reproduce:

1. Install Firefox app through the Play store
2. Install the LastPass addon and log in to LastPass with your username and password
3. Start the app



Actual results:

After a few seconds the app freezes for approximately 40-50 seconds. If you try closing the app it will do it slowly but it seems to slow down Android


Expected results:

The app should start up normally.

Postscript: I have put this to LastPass but they blamed the Firefox code for it
I also tried it on the latest Firefox for Android Beta 28. Same issue.
Keywords: addon-compat, hang
OS: Linux → Android
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Keywords: perf
Which device, which version of Android?
This sounds like bug 847019.
(In reply to Aaron Train [:aaronmt] from comment #2)
> Which device, which version of Android?

Apologies. This happened on GT-I9300 and GT-I9100 and on different versions of Android. currently the GT-I9300 has Android 4.3 but was happening on previous versions 4.2...

Since Firefox for Android 27 the Firefox app sometimes even crashes and I am able to send a crash report. However I cannot see crash reports under about:crashes
Hi Lastpass,

Can you detail what is happening on startup that might be causing issues?
I am unable to reproduce this on my Nexus 5.

First, please confirm that this issue exists with the latest version of LastPass (3.1.0) that is available from our website.  The version on AMO is very old and Mozilla has refused to update it.
(In reply to Andrew Zitnay from comment #6)
> The version on AMO is very old and Mozilla has refused to update it.
Flags: needinfo?(jorge)
(In reply to Andrew Zitnay from comment #6)
> I am unable to reproduce this on my Nexus 5.
> 
> First, please confirm that this issue exists with the latest version of
> LastPass (3.1.0) that is available from our website.  The version on AMO is
> very old and Mozilla has refused to update it.

The latest LastPass addon version I can get hold off through Mozilla is 2.0.20.
Now what is this about Mozilla refusing to update the addon. Why the heck are we having this discussion when I am unable to really update to latest version. 
This issue should be put on hold. First we need to get the addon updated. How can Mozilla refuse to update it?
(In reply to Andrew Zitnay from comment #6)
> I am unable to reproduce this on my Nexus 5.
> 
> First, please confirm that this issue exists with the latest version of
> LastPass (3.1.0) that is available from our website.  The version on AMO is
> very old and Mozilla has refused to update it.

By the way the latest version of the addon on LastPass's website is 3.0.10 and not 3.1.0
As a Premium LastPass user I should have been informed about this in my opinion.
When I originally raised this question with LastPass I was told that Firefox code was to blame. Although I did raise this issue a while ago and the update problem might have not existed.
(In reply to Aaron Train [:aaronmt] from comment #7)
> (In reply to Andrew Zitnay from comment #6)
> > The version on AMO is very old and Mozilla has refused to update it.

There's a version pending review. I don't know what has happened with previous versions since I wasn't the reviewer, but large complex add-ons tend to take very long to review and can have a number of issues that require multiple iterations before a new version is accepted.
Flags: needinfo?(jorge)
The last version of LastPass that was approved on AMO was 2.0.20, which was released almost a year ago.  It's my understanding from another developer that ever since then, the AMO portal times out while we're attempting to upload our updates.  We then have to manually send the updates to the reviewers.  Weeks go by and we hear nothing.

For obvious reasons, we no longer recommend our users download from AMO.  We recommend downloading from our website, which will always have the most recent version.

As for 3.0.10 vs. 3.1.0, I believe we haven't yet bumped the version number for upgrade purposes.  However, if you download https://lastpass.com/lp.xpi it'll be 3.1.0.

As for this bug report, please let me know if it's reproducible with 3.1.0.  If so, we can debug further.  If not, the workaround is to install from our website.
I can confirm trying it several times that Firefox does not hang anymore using LastPass 3.1.0

This bug is not reproducable on my system with the LastPass addon downloaded directly from the LastPass server
Status: NEW → RESOLVED
blocking-b2g: --- → fugu?
Closed: 6 years ago
Resolution: --- → WORKSFORME
blocking-b2g: fugu? → ---
tracking-fennec: ? → ---
Whiteboard: [workaround: install https://lastpass.com/lp.xpi]
If this is causing startup hangs, we should block affected versions on Android.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Hardware: x86_64 → All
If there's a version for Android pending review on AMO and it passes review, I think it's best to let users update to the new version. If the hangs prevent a significant portion users from updating, then we can consider blocklisting. However, even in that case it's debatable whether the blocklist will be effective.
Closing this as it relates to a very old version and there are newer bugs dealing with LastPass performance for more recent versions.
Status: REOPENED → RESOLVED
Closed: 6 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.