Closed Bug 973313 Opened 7 years ago Closed 7 years ago

mach build installer doesn't include vccorlib120.dll on VC12 with --enable-metro and WIN32_REDIST_DIR is specified

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla30

People

(Reporter: emk, Assigned: emk)

References

Details

Attachments

(1 file, 1 obsolete file)

Because vccorlib120.dll is not copied to $objdir/dist/bin.
Attached patch patch (obsolete) — Splinter Review
Attachment #8376798 - Flags: review?(robert.strong.bugs)
Comment on attachment 8376798 [details] [diff] [review]
patch

Let's ask Jim for review since he has been working on metro
Attachment #8376798 - Flags: review?(robert.strong.bugs) → review?(jmathies)
Component: General → Build Config
Product: Firefox → Core
Summary: mach build installer fails on VC12 with --enable-metro and WIN32_REDIST_DIR is specified → mach build installer doesn't include vccorlib120.dll on VC12 with --enable-metro and WIN32_REDIST_DIR is specified
We shouldn't need this library anymore. In fact this reference can be removed - 

http://mxr.mozilla.org/mozilla-central/source/browser/installer/package-manifest.in#102
OK, let's remove it.
Attachment #8376798 - Attachment is obsolete: true
Attachment #8376798 - Flags: review?(jmathies)
Attachment #8377116 - Flags: review?(jmathies)
Attachment #8377116 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/8fa60c3a947e
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Flags: in-testsuite-
https://hg.mozilla.org/mozilla-central/rev/8fa60c3a947e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Duplicate of this bug: 888637
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.