Closed Bug 973529 Opened 6 years ago Closed 6 years ago

In Firefox Account "Sign In" screen (on Android), keyboard pushes "Email" field offscreen, when typing in email, in Landscape orientation

Categories

(Firefox for Android :: Android Sync, defect, P3)

Firefox 30
All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox28 --- unaffected
firefox29 --- wontfix
firefox30 --- wontfix
firefox31 --- verified
fennec 29+ ---

People

(Reporter: dholbert, Assigned: nalexander)

References

Details

Attachments

(3 files)

STR:
 0. (Clear existing Sync settings.)
 1. In Firefox for Android settings, tap Sync
 2. Tap "Get Started"
 3. Tap the "Email" field, to bring up the keyboard.
 4. Now rotate your device into landscape orientation, so that you can better-use your keyboard.

ACTUAL RESULTS: The "Email" field (where I'm typing) is now completely offscreen.

EXPECTED RESULTS: The field should be visible. (via scrolling the content, or something)


NOTE: The same thing happens for the "Password" field on this "new account" page, and also happens on the "already have an account? sign in" page's Email field.
(Actually, it looks like I can touch to scroll the page, but not enough to bring the fields into view.)
(elaborating slightly on comment 1 -- it lets me scroll to bring content out from *behind the keyboard*, but not to bring content into view that's *off the top of the page)

The device I'm testing on is a Nexus 7, with Android 4.4.2 and Firefox Nightly.
Attached image screenshot of STR
Here's a screenshot taken after performing the STR. The cursor is currently in the "Email" field, which is offscreen and impossible to view (AFAICT), with its friend the Password field.
and here's a screenshot of what happens if I modify the STR to use the "Already have account? sign in" page (instead of the "new account" page)
Component: FxA → Android Sync
Product: Firefox for Android → Android Background Services
Version: unspecified → Firefox 30
Duplicate of this bug: 973626
tracking-fennec: --- → ?
tracking-fennec: ? → 29+
Still a concern with latest layout?
Flags: needinfo?(aaron.train)
Yep (sorry for delay). In landscape on my 10" tablet, it nudges everything off-screen when the email field gets focus.
Flags: needinfo?(aaron.train)
Assignee: nobody → nalexander
Priority: -- → P3
This looks an examplar of a class of Android tablet bugs: different OS versions and devices just don't handle displaying input fields around the keyboard well.  I will investigate whether we're doing something foolish in the activity manifest or the layout itself.
Device tested on my Transformer Prime.  And I confirmed the initial bug.
Attachment #8404993 - Flags: review?(rnewman)
(In reply to Nick Alexander :nalexander from comment #8)
> This looks an examplar of a class of Android tablet bugs: different OS
> versions and devices just don't handle displaying input fields around the
> keyboard well.  I will investigate whether we're doing something foolish in
> the activity manifest or the layout itself.

We were doing something wrong (but not foolish!) in the layout styles.  Thanks for the detailed report, dholbert!
Comment on attachment 8404993 [details] [review]
Link to Github pull-request: https://github.com/mozilla-services/android-sync/pull/450

If it verifies, lgtm.
Attachment #8404993 - Flags: review?(rnewman) → review+
(In reply to Richard Newman [:rnewman] from comment #11)
> Comment on attachment 8404993 [details] [review]
> Link to Github pull-request:
> https://github.com/mozilla-services/android-sync/pull/450
> 
> If it verifies, lgtm.

Verified locally on my Transformer Prime.  We'll get QA verification, of course -- those peeps are awesome.
Status: NEW → ASSIGNED
Keywords: qawanted
https://hg.mozilla.org/mozilla-central/rev/6edb3b4eba0c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Verified as fixed in build 31.0a1 (2014-04-18);
Device: Lenovo Yoga Tab 10 (Android 4.2.2).
Considering that the Firefox 30 was released I will change flags for FF29 and FF30 to wontfix;
Based on comment 15 I will mark the bug as verified.
Status: RESOLVED → VERIFIED
Keywords: qawanted
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.