Closed Bug 973754 Opened 9 years ago Closed 5 years ago

https://www.google.com offers "voice search" in Chrome but not Firefox

Categories

(Web Compatibility :: Desktop, defect, P3)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1248897

People

(Reporter: roc, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [country-all] [js] [notcontactready])

Attachments

(1 file)

AFAIK we support everything you'd need to do voice search at least as well as Chrome does (getUserMedia and MediaRecorder).
Assignee: english-other → nobody
Component: English Other → Desktop
Whiteboard: [country-all] [js] [notcontactready]
I suppose they may only be looking for navigator.webkitGetUserMedia() but I haven't found the relevant code with a brief look.
How do you reproduce the bug? Even when faking a Chrome User Agent on Firefox Desktop (Not logged to Google) I don't see any search feature by voice.
Attached image gvoice.png
I reproduce simply by loading the site in Chrome - there is a small microphone icon inside the search box as in this screenshot.
fwiw, Using Opera (blink) and Safari, latest versions, I have no microphones either. 
This is a bug for webcompat.com ^_^
Old bug… which was not finished in terms of analysis.
I guess they use webkitSpeechRecognition

```
var QS_L8 = - 1,
QS_M8 = 0,
QS_Z$c = function () {
  QS_A8 = new webkitSpeechRecognition;
  QS_A8.continuous = !1;
  QS_A8.interimResults = !0;
  QS_A8.lang = QS_E$c;
  QS_A8.maxAlternatives = 4;
  QS_A8.onerror = QS_T$c;
  QS_A8.onnomatch = QS_U$c;
  QS_A8.onend = QS_V$c;
  QS_A8.onresult = QS_W$c;
  QS_A8.onaudiostart = QS_X$c;
  QS_A8.onspeechstart = QS_Y$c
},
```

and

```
init: function (a) {
QS_E$c = a.hl;
var b;
if (b = 'webkitSpeechRecognition' in self && !!webkitSpeechRecognition) {
  QS_I8 = QS_k('spch');
  QS_J8 = QS_k('spchc');
  QS_O$c = QS_dad;
  if (b = !!QS_I8 && !!QS_J8) QS_E8 = QS_k('spchf'),
  QS_F8 = QS_k('spchi'),
  QS_M$c(),
  b = !(!QS_E8 || !QS_F8);
  b && (QS_F$c = QS_k('spchb'), QS_D8 = QS_k('spchl'), b = !(!QS_F$c || !QS_D8))
}
```


https://developers.google.com/web/updates/2013/01/Voice-Driven-Web-Apps-Introduction-to-the-Web-Speech-API?hl=en
https://dvcs.w3.org/hg/speech-api/raw-file/tip/speechapi.html

And probably a duplicate of Bug 1248897
Flags: needinfo?(hsteen)
I find your analysis very credible, Karl. We can keep this as [notcontactready] til that bug is fixed..
Depends on: 1248897
Flags: needinfo?(hsteen)
Priority: -- → P3
Let's just close this as a dupe of Bug 1248897.
Status: NEW → RESOLVED
Closed: 5 years ago
No longer depends on: 1248897
Resolution: --- → DUPLICATE
Duplicate of bug: 1248897
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.