Closed Bug 973806 Opened 9 years ago Closed 8 years ago

video.disney.co.jp sends desktop content, shows flash error instead of video

Categories

(Web Compatibility :: Mobile, defect)

Other
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: hsteen, Assigned: karlcow)

References

()

Details

(Whiteboard: [mobile-compat-form][serversniff][country-jp][sitewait][video])

Attachments

(3 files)

Site: http://video.disney.co.jp
video.disney.co.jp sends desktop content, shows flash error instead of video

:: Steps To Reproduce

Loading video.disney.com takes me to video.disney.co.jp. This site mistakenly believes that the Firefox OS smartphone is a desktop browser, and hence does not redirect to the mobile version of the site. The main problem is that videos do not play - we get an "install Flash" banner instead.

:: Expected Result

Video

:: Actual Result

Flash error

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
Firefox Android gets redirected to http://video.disney.co.jp/sp/?redirect=true, Firefox OS is not redirected

Selected HTTP response headers:

Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
Response Status: 200
content-length: 37384
content-type: text/html

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 302
content-length: 0
location: http://video.disney.co.jp/sp/?redirect=true
content-type: text/html
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form][serversniff][country-all][contactready][video]
Attached image disney.video.com.png
Here in the US both Firefox OS and Firefox for Android are served a mobile optimized site (with working video), for video.disney.com:

Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
status: 200 OK
content-length: 24777



Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
status: 200 OK
content-length: 24777
age: 185
Good, so it's a more local problem - marking it country-jp
Whiteboard: [mobile-compat-form][serversniff][country-all][contactready][video] → [mobile-compat-form][serversniff][country-jp][contactready][video]
Attached image 2014-07-01-13-35-49.png
When I request http://video.disney.co.jp/sp/
on Firefox OS, note that there are the usual display issues due to webkit only CSS with gradients for example.
First attempt at contact
http://twitter.com/MozWebCompat/status/483865373012267008
http://www.linkedin.com/in/yujiendo
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [mobile-compat-form][serversniff][country-jp][contactready][video] → [mobile-compat-form][serversniff][country-jp][sitewait][video]
The issue is happening also for the main site.
http://www.disney.co.jp/ redirects to Mobile on iOS (http://www.disney.co.jp/sp/) but not on Firefox OS.
Depends on: 987550
the site nows redirects to http://www.disney.co.jp/news/20140930_01.html
The site has been stopped since September 30, 2014.
Closing as INVALID.

irony: the news is mobile friendly. ;)
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.