Closed Bug 973853 Opened 7 years ago Closed 7 years ago

Images are not displayed the second time in link and import views

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S2 (28feb)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: crdlc, Assigned: crdlc)

References

Details

(Keywords: regression)

Attachments

(1 file)

The first time when users try to import contacts, images are displayed correctly. But consecutive times, they are not displayed until the app is killed
Depends on: 959414
Keywords: regression
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached file Patch v1
Attachment #8377501 - Flags: review?(jmcf)
Comment on attachment 8377501 [details]
Patch v1

thanks!
Attachment #8377501 - Flags: review?(jmcf) → review+
Merged in master:

https://github.com/crdlc/gaia/commit/1d81c792f93f886f5ea227ee1e5c44ffcb996f70
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S2 (28feb)
blocking-b2g: --- → 1.3?
I've just nominated it because after landing this bug 959414 as cherry pick instead of using the proper pull request done to fix that issue without this new problem described here, the v1.3 is affected by this bug as well. The risk is completely close to null and strictly necessary

Thanks a lot
blocking-b2g: 1.3? → 1.3+
(In reply to Cristian Rodriguez (:crdlc) from comment #4)
> I've just nominated it because after landing this bug 959414 as cherry pick
> instead of using the proper pull request done to fix that issue without this
> new problem described here, the v1.3 is affected by this bug as well. The
> risk is completely close to null and strictly necessary
> 
> Thanks a lot

Fail, sorry :(

That said, this still needs to go through the approval process.
Flags: needinfo?(crdlc)
Comment on attachment 8377501 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 959414
[User impact] if declined: very high (no images in import & link views the second time and consecutives)
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]:
Attachment #8377501 - Flags: approval-gaia-v1.3?(fabrice)
Flags: needinfo?(crdlc)
Attachment #8377501 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
Hi John,

Could you please help us with the uplift to v1.3 branch?. Thanks!
Flags: needinfo?(jhford)
Uplift successful
Uplifted 70c72c50e9cc17503ece37c990a3d0242664b9b1 to:
  * v1.3: 8fce95f4beee8caf82802fe0bf0b08425b7a4071
Flags: needinfo?(jhford)
You need to log in before you can comment on or make changes to this bug.