Closed Bug 974129 Opened 6 years ago Closed 6 years ago

Change: replace cloud and Firefox icons in Getting Started

Categories

(Firefox for Android :: Android Sync, defect, P1)

Firefox 29
All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
fennec 29+ ---

People

(Reporter: rnewman, Assigned: nalexander)

References

Details

Attachments

(2 files)

Assignee: nobody → nalexander
Blocks: 972888
Priority: -- → P1
jgruen, ibarlow: I have a link to a single resolution of this.  I'll need some selection of ldpi, mdpi, hdpi, xhdpi, xxhpdi -- ibarlow is the right person to determine which are necessary, and what the appropriate sizes are.
Flags: needinfo?(jgruen)
Flags: needinfo?(ibarlow)
Further to this -- can I get confirmation that we want to show the Firefox fox icon regardless of the release channel?  The branding for everything else -- the icons shown in the Android Account Settings pane, for example -- is the channel branding.

I'm a bit worried about shipping Firefox branding without regard to channel, since we explicitly support re-packagers who do not include our branding at all.  This makes it harder for them to respect Mozilla's mark.
I've asked Anthony to pull together some graphics for you, Nick. 

As for the Firefox icon, I don't know who the decision maker is for that, though my sense is that we would *not* want to change the icon in the sign-in flow based on release channel. Desktop doesn't seem to either. I realize this creates inconsistency with our Account Settings pane, but I'm not convinced that is especially important here.
Flags: needinfo?(ibarlow)
ian, anthony: the vector version of the updated cloud icon thing can be found in this sketch file: 
https://www.dropbox.com/sh/l97u5auulsrvdb6/U_9wueOCwv
Flags: needinfo?(jgruen)
Based on past experience, we've been pretty solid about only using the Firefox brand in officially-branded builds.  Health Report, Sync, Help, etc have all avoided hardcoding anything to do with our trademark to avoid issues with consumer of our code.
(In reply to Mike Connor [:mconnor] from comment #5)
> Based on past experience, we've been pretty solid about only using the
> Firefox brand in officially-branded builds.  Health Report, Sync, Help, etc
> have all avoided hardcoding anything to do with our trademark to avoid
> issues with consumer of our code.

This is totally understandable. If its problematic to hard code the logo, lets not do it. Alternate possibility, could we just load the correct asset from the fxa content server?
We already have existing branding support in the build system, we'd just need generic and official variants of the various assets.  Nick knows the rest.

(Lets not build a remote dependency where none is needed!)
(In reply to John Gruen from comment #4)
> ian, anthony: the vector version of the updated cloud icon thing can be
> found in this sketch file: 
> https://www.dropbox.com/sh/l97u5auulsrvdb6/U_9wueOCwv

This link is dead.  Note to everybody in the universe: Dropbox links must be considered ephemeral.  I'm really not the right person to produce rasterized versions of icons; please, somebody who deals with .sketch files, produce PNGs in appropriate sizes and attach them to this ticket.
Flags: needinfo?(jgruen)
Flags: needinfo?(ibarlow)
Nick, I prepped the graphic in question and have it attached here from LDPI -> XXHDPI

https://people.mozilla.org/~alam/Assets/FxA_sync_getstarted_Android.zip
(In reply to Anthony Lam from comment #9)
> Nick, I prepped the graphic in question and have it attached here from LDPI
> -> XXHDPI
> 
> https://people.mozilla.org/~alam/Assets/FxA_sync_getstarted_Android.zip

These look good.  I bumped the sizes up (using the xxhpdi icon for xhdpi, xhdpi for hdpi, etc) since that's closer to what we had before, and looks better on my devices.  Plus, Fennec essentially doesn't use xxhdpi.

Finally, we use pngquant to crush these.  They're < 256 colors so the crush is lossless.  They look great, thanks!
> Finally, we use pngquant to crush these.  They're < 256 colors so the crush
> is lossless.  They look great, thanks!

Sorry, this is a lie.  They're all 400-800 colors; they appear to crush very well.  I certainly see no artifacts, but we can always iterate.
Following discussion with rnewman, I am going to do the following:

Use the channel branding logo throughout.

This is the path that fits with how Firefox is presented to re-packagers.  In the cases that we care most about (Release and Beta), these choices yield:

Release: Firefox logo;
Beta: Firefox logo with beta corner overlay.

(See http://mxr.mozilla.org/mozilla-central/source/mobile/android/branding/official and http://mxr.mozilla.org/mozilla-central/source/mobile/android/branding/beta, respectively.)

In re-packaged builds, this would yield a non-Firefox logo.  Bug 974133 is pretty clear that we're rolling with "Firefox Account", even in re-packaged builds, so we'll just have to deal with this inconsistency.
I checked in with DRIs; the answer I could get in the time agreed with the decision we laid out this morning.

We'll go with the noun phrase "Firefox Account" in all channels (as we have done), and per-channel logo branding. If that decision changes, it changes, and we'll do what we can in Beta based on risk and effort assessments.
A slight refinement to the plan, which I think we can address later: we might want to use the Firefox logo for all Mozilla-sourced builds, regardless of channel. Let's land this for now and iterate.
Attached patch Part 1.Splinter Review
Attachment #8391018 - Flags: review+
Attached patch Part 2.Splinter Review
Attachment #8391019 - Flags: review+
Status: NEW → ASSIGNED
tracking-fennec: --- → 29+
Comment on attachment 8391018 [details] [diff] [review]
Part 1.

Requesting uplift on nalexander's behalf for both patches.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Requested UI changes for 29.

User impact if declined: 
  Worse UI.
  
Testing completed (on m-c, etc.): 
  Landed and tested on m-c.

Risk to taking this patch (and alternatives if risky): 
  None.

String or IDL/UUID changes made by this patch:
  None.
Attachment #8391018 - Flags: approval-mozilla-aurora?
Attachment #8391018 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(ibarlow)
Product: Android Background Services → Firefox for Android
Flags: needinfo?(jgruen)
You need to log in before you can comment on or make changes to this bug.