Cache issues when network connection gets dropped.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Build ID:  2001-08-28-03, Windows 2000.

Summary: Cache issues when network connection gets dropped.

Steps to Reproduce:

1.  Connect to a newsserver (I used news://poisonivy.mcom.com) and subscribe to
a group.
2.  Read a couple of postings, doesn't matter what you read.
3.  Drop your connection to the network (if on dialup, disconnect, if on LAN,
pull RJ-45 cable or do ipconfig/release on a win2k box).
4.  Try to read a message (you get 2 errors, both connection-related [why 2?
might be a seperate bug]).
5.  Now, reconnect to the network by doing ipconfig/renew or dialing up.
6.  Attempt to read messages.

Expected Results:

Messages, whether read or not, will display 100%.

Actual Results:

Especially in threads it seems, we are not reading from the cache correctly, or
invalidating from the cache.  Screenshots to follow.  One before shot, one after
shot.
Keywords: nsbranch
*** Bug 97025 has been marked as a duplicate of this bug. ***
OS: Windows 2000 → All
Hardware: PC → All

Updated

17 years ago
Blocks: 99230

Comment 4

17 years ago
not an emojo stopper.
Keywords: nsbranch → nsbranch-
Hopefully, the log is helpful.  Here are my steps to produce that log:

Messages "test123" and "test456" were unread messages.  Message "there can only 
be one" was a message I have already read.

1.  In netscape.test, I read "test123" with my cable connection still alive.
2.  Disconnected my connection, and attempted to read a read message ("there 
can only be one").
3.  Waited for timeout
4.  Read "test456" (this didn't display correctly)
5.  Read "test123", which finally loaded correctly.
Seems bug 59449's fix corrects this, or helps it tremendously.  But I'll keep
testing.
it makes sense that the fix for #59449 fixes this, but I'll have to debug to
confirm.

I'd like to leave this bug open because I bet that when the connection gets
dropped we're leaking the protocol instance.

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-

Updated

17 years ago
No longer blocks: 107067
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 10

11 years ago
has a log file
QA Contact: stephend → networking.news
Can't reproduce -> WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.