Closed Bug 974258 Opened 6 years ago Closed 2 years ago

History shown in Location Bar is no longer constrained by urlbar width when using the drop-down arrow

Categories

(SeaMonkey :: Location Bar, defect)

x86_64
Windows 7
defect
Not set

Tracking

(firefox29 fixed, firefox30 fixed, seamonkey2.26 verified, seamonkey2.27 verified)

RESOLVED FIXED
seamonkey2.27
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
seamonkey2.26 --- verified
seamonkey2.27 --- verified

People

(Reporter: rsx11m.pub, Assigned: neil)

Details

(Keywords: regression)

Attachments

(2 files)

Steps to reproduce on aurora or trunk channels:

1. Optional: In the History preferences, click "Clear Location Bar"
2. Visit some page with a long URL (e.g., search something in bugzilla)
3. Click in the Location Bar and hit Enter to add it to its history
4. Now click on the arrow-down button to the left of the Location Bar
5. The list of suggested URLs spans across the full screen width

Expected result:

5. The list is constrained by the width of the urlbar element.

Screenshot follows for illustration. Note that the list for the regular auto-complete history (when just typing without clicking the arrow) isn't affected and remains properly constrained in width.
SM 2.25a2 (bottom) vs. 2.26a2 (top), also observed on current 2.27a1 build.
> 4. Now click on the arrow-down button to the left of the Location Bar
You mean to the "right" don't you?
Confirm I see this too.

Neil has something changed in toolkit or gecko?
Flags: needinfo?(neil)
(In reply to Philip Chee from comment #2)
> You mean to the "right" don't you?

Yes, autocomplete-history-dropmarker.
Well, the (Nothing Available) is supposed to stretch to the full width too...
Regression range: 4da3e21a0e5f::7e79536aca0a - bug 941409 looks suspicious, since it changed things so that IsSizedToPopup is only called for menus, which this isn't. The main autocomplete popup works around the problem by explicitly setting the width on the popup before opening it.
Flags: needinfo?(neil)
Attached patch WorkaroundSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8378716 - Flags: review?(philip.chee)
Attachment #8378716 - Flags: feedback?(rsx11m.pub)
FYI the code is copied from the similar openPopup method.
Comment on attachment 8378716 [details] [diff] [review]
Workaround

Solves it for me with a quick test on trunk.  :-)
Attachment #8378716 - Flags: feedback?(rsx11m.pub) → feedback+
Blocks: 974824
No longer blocks: 974824
Comment on attachment 8378716 [details] [diff] [review]
Workaround

>-    <content sizetopopup="pref">
>+    <content>
(We should also do this to urlbarBindings.xml)
Comment on attachment 8378716 [details] [diff] [review]
Workaround

r=me
Attachment #8378716 - Flags: review?(philip.chee) → review+
https://hg.mozilla.org/mozilla-central/rev/676016cd743d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.27
Comment on attachment 8378716 [details] [diff] [review]
Workaround

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 941409
Risk to taking this patch (and alternatives if risky): None; code path is only used by SeaMonkey
String or IDL/UUID changes made by this patch: None
Attachment #8378716 - Flags: approval-mozilla-aurora?
Whiteboard: [don't autoland]
Attachment #8378716 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed in current 2.27a1 and 2.26a2 Windows nightly builds. Thanks!
Status: RESOLVED → VERIFIED
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/e34ccb9162d1
Manually size autocomplete history popup to the autocomplete's width r=Ratty
https://hg.mozilla.org/comm-central/rev/532337d61c38
Manually size autocomplete history popup to the autocomplete's width r=Ratty
Status: VERIFIED → RESOLVED
Closed: 6 years ago2 years ago
You need to log in before you can comment on or make changes to this bug.