Closed Bug 974380 Opened 7 years ago Closed 2 years ago

crash in java.lang.UnsupportedOperationException: Unknown query URI content://org.mozilla.firefox_beta.db.browser/bookmarks?profile=webapp1&limit=1 at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java)

Categories

(Firefox for Android :: General, defect)

28 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox28 --- affected
firefox29 --- ?
firefox30 --- ?

People

(Reporter: csuciu, Unassigned)

Details

(Keywords: crash, steps-wanted)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-568e6863-8fd9-4080-9e00-9aaf72140219.
=============================================================

java.lang.UnsupportedOperationException: Unknown query URI content://org.mozilla.firefox_beta.db.browser/bookmarks?profile=webapp1&limit=1 at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java:168) at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java:136) at android.content.ContentProviderProxy.bulkQueryInternal(ContentProviderNative.java:369) at android.content.ContentProviderProxy.query(ContentProviderNative.java:405) at android.content.ContentResolver.query(ContentResolver.java:302) at org.mozilla.gecko.db.LocalBrowserDB.isBookmark(LocalBrowserDB.java:475) at org.mozilla.gecko.db.BrowserDB.isBookmark(BrowserDB.java:227) at org.mozilla.gecko.Tab$2.run(Tab.java:435) at android.os.Handler.handleCallback(Handler.java:587) at android.os.Handler.dispatchMessage(Handler.java:92) at android.os.Looper.loop(Looper.java:132) at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:32
Flags: needinfo?(catalin.suciu)
Keywords: steps-wanted
This crash occurred after I've added a page to the reading list then tapped on the reading list button but this are not reliable steps since I'm not able to reproduce it.
Flags: needinfo?(catalin.suciu)
Crash Signature: [@ java.lang.UnsupportedOperationException: Unknown query URI content://org.mozilla.firefox_beta.db.browser/bookmarks?profile=webapp1&limit=1 at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java)] → [@ java.lang.UnsupportedOperationException: Unknown query URI content://org.mozilla.firefox_beta.db.browser/bookmarks?profile=webapp1&limit=1 at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java)] [@ java.lang.UnsupportedOperation…
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
You need to log in before you can comment on or make changes to this bug.