scrolling widgets fails to move drop down windows

VERIFIED FIXED

Status

()

Core
Event Handling
P3
normal
VERIFIED FIXED
19 years ago
9 years ago

People

(Reporter: blizzard, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
This shows up on test16.html.  To reproduce it, open the drop down list for
the gears test and then scroll.  The dropped down window will not move with
the other widgets.
(Assignee)

Comment 1

19 years ago
This is probably a problem with nsWidget::WidgetShow().  It should probably do
an XMoveWindow() before mapping the window to make sure it's in the right
place.  Its bounds might have been adjusted since the last time it was mapped
and it will show up in the wrong place.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
This has been fixed.

Updated

18 years ago
Keywords: verifyme
(Assignee)

Comment 3

18 years ago
Please ignore the spam.  Changing address.
Assignee: blizzard → blizzard
Status: RESOLVED → NEW
(Assignee)

Comment 4

18 years ago
busted from my reassign
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago

Comment 5

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 6

17 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 8

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Comment 9

17 years ago
verified on build 2001-07-30-08-trunk
Status: RESOLVED → VERIFIED

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.