Compact Folders crashes

VERIFIED DUPLICATE of bug 97497

Status

--
critical
VERIFIED DUPLICATE of bug 97497
18 years ago
7 years ago

People

(Reporter: bugzilla-mozilla-org, Assigned: naving)

Tracking

({crash, dataloss})

Trunk
x86
Linux
crash, dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Selecting "Compact Folders" crashes Mozilla approximately once every 20 times. 
The folder is correctly compacted, but the UI freezes for a second and then
disappears.  (In fact, this just happened while I was writing the original
version of this bug report.)  Talkback does not appear, and I can't currently
generate this at will (by repeatedly selecting "Compact Folders"), so I'm unable
to provide much more information.

Mozilla 2001082808 (and previous builds for at least a week), Red Hat Linux 7.1,
UW IMAP 2000c.

Comment 1

18 years ago
*** Bug 97260 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
severity, keywords

reporter of the dup (bernard@digitalobjects.co.nz) claims that this destroyed
his inbox, so +dataloss
Severity: normal → critical
Keywords: crash, dataloss
over to naving.
Assignee: sspitzer → naving
(Assignee)

Comment 4

18 years ago
So, Is this imap or local ?

Comment 5

18 years ago
reporter's description says IMAP.
Also,  see bug 97497, a topcrash bug which has talkback comments about
compacting folders 

Comment 6

18 years ago
this looks like it could be really nasty. adding some keywords
Keywords: nsbranch, nsenterprise
(Assignee)

Comment 7

18 years ago
reporter, please clarify if it is imap or local. If it is imap, it could be
a dup of bug 97497

Updated

18 years ago
QA Contact: esther → huang

Comment 8

18 years ago
From reporter's description. It's on UW IMAP 2000c.......
bug 97497 included many crash scenarios. I am marking this bug as dup of that 
bug.....

*** This bug has been marked as a duplicate of 97497 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 10

18 years ago
Local not imap in my case

Comment 11

18 years ago
I added comments for Local Folder on bug 97497 already.
(Assignee)

Comment 12

18 years ago
I just checked in a fix for bug 97246 - which may be the crash for local 
folders compact. 
(Reporter)

Comment 13

18 years ago
Yes, it's IMAP, but I see this has been dup'd already anyway.
(Reporter)

Comment 14

17 years ago
Per mail from Karen Huang I'm reopening this bug, as it now appears to be
different than bug 97497.  I've just submitted a new TalkBack log too,
TB36725410Z, from Linux trunk -sea nightly 2001100808.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Updated

17 years ago
Blocks: 104864
(Assignee)

Comment 15

17 years ago

*** This bug has been marked as a duplicate of 104659 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
No longer blocks: 104864
(Assignee)

Comment 16

17 years ago
sorry, this bug is about imap crash which is covered in bug 97497
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 17

17 years ago

*** This bug has been marked as a duplicate of 97497 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 18

17 years ago
Navin, this bug isn't fixed, and was duplicated to 97497 before.  Reports in bug
97497 say that it has been fixed, so it was suggested *by Mozilla QA* that I
reopen this one.  After I did so, it was almost immediately marked a dup of bug
104659, and now you've marked it a dup of the (fixed) 97497 again.

I crashed Mozilla not 10 minutes ago with these exact symptoms.  Neither 97497
or 104659 has affected this behaviour in the least.
(Assignee)

Comment 19

17 years ago
This is a duplicate of bug 97497 because it is the imap folder compact 
crash. Since bug 97497 has more info, I will reopen that one.

Comment 20

17 years ago
Peter, since we reopened bug 97497 -- I am verifying this bug dup of bug 97497 
,thanks for testing this bug. 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.