Closed Bug 974560 Opened 6 years ago Closed 6 years ago

"Assertion failure: mLastData == aTextEvent->theText" when inputting text in debug build

Categories

(Firefox for Android :: Keyboards and IME, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30

People

(Reporter: jchen, Assigned: jchen)

References

Details

Attachments

(1 file)

No description provided.
We are supposed to send a compositionupdate event for every text event. This patch sends the missing composition events. For keys with multiple action, that code should never be reached and I removed the code that was sending text events.
Attachment #8378608 - Flags: review?(cpeterson)
Comment on attachment 8378608 [details] [diff] [review]
Send compositionupdate event for each text event (v1)

Review of attachment 8378608 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8378608 - Flags: review?(cpeterson) → review+
Duplicate of this bug: 975409
https://hg.mozilla.org/mozilla-central/rev/ba82c75ac11c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Thank you for the bug of compositionupdate event.

FYI: I'll move the compositionupdate dispatcher from every widget to TextComposition for avoiding widget dependent bugs like this. See bug 975383.
You need to log in before you can comment on or make changes to this bug.