Closed Bug 974771 Opened 6 years ago Closed 6 years ago

Currently downloading file can be attempted to open

Categories

(Firefox for Android :: Download Manager, defect)

28 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30

People

(Reporter: ashish, Assigned: esawin)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140213004002

Steps to reproduce:

Open a large enough file for download, say an .apk. While the download is in progress, open Menu > Tools > Downloads and tap on the file.


Actual results:

Firefox attempts to open the file which unsurprisingly results in errors


Expected results:

Until the download completes, the only available actions should be Pause/Resume or Cancel
I figure this will go away once we transition to the native system download application. On my Nexus 5 running Android 4.4.2, I notice that on attempt to access the in-progress download in the application nothing will happen.

Perhaps Josh with his current set of in-progress patches can verify this?
Flags: needinfo?(jdover)
I'm referencing bug 816318 in comment #1.
Depends on: 816318
Yes this won't be an issue once work on bug 816318 is finished, but this could persist on Froyo devices as they will continue to use the old download manager.
Flags: needinfo?(jdover)
We could simply ignore the open request, or do we want to show a warning message?
What does the system download manager do in this case, to make it consistent?
Flags: needinfo?(jdover)
The system download manager opens up the download list, so we could open about:downloads.
Flags: needinfo?(jdover)
Assignee: nobody → esawin
Attachment #8386127 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8387067 - Flags: review?(wjohnston)
Comment on attachment 8387067 [details] [diff] [review]
Ignore open request for unfinished download

Review of attachment 8387067 [details] [diff] [review]:
-----------------------------------------------------------------

We could probably show a dialog with some options, but since this UI is dying, that's a waste of time :)
Attachment #8387067 - Flags: review?(wjohnston) → review+
Agreed, also the system download manager does not provide any options in that case either, so what we here is more or less consistent.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c64ce8e54e04
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
You need to log in before you can comment on or make changes to this bug.