Closed Bug 974864 Opened 6 years ago Closed 6 years ago

[MMS]Pick recipient(email adress) up from contacts app

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ta-matsuura, Assigned: na-matsumoto)

References

Details

Attachments

(1 file, 3 obsolete files)

46 bytes, text/x-github-pull-request
julienw
: review+
arcturus
: review+
Details | Review
[User story]
1. Run message app
2. Create new message
3. Tap "+" to set recipient from contacts app

Then User can choose "Phone number" or "Email address".
So before jump to contact, one screen needed to choose.
Blocks: 974333
Assignee: nobody → na-matsumoto
Group: kddi-confidential
Summary: [MADAI][MMS]Pick recipient(email adress) up from contacts app → [MMS]Pick recipient(email adress) up from contacts app
Depends on: 972573
Target Milestone: --- → 2.0 S4 (20june)
> So before jump to contact, one screen needed to choose.
We dont have to show a screen to choose phone or address since bug 972573 will be fixed.
Attached file PR review: Bug974864 (obsolete) —
Hi Francisco,

I know Bug972573 is not yet fixed.
But I want review this attachment.
Because I am working for Target Milestone.

Thanks.
Attachment #8440633 - Flags: review?(francisco)
Comment on attachment 8440633 [details] [review]
PR review: Bug974864

This patch already includes the patch in bug 972573, that it's almost ready but still not landed.

We will need to wait till tomorrow, once we land bug 972573 to have the specific code for this bug, other wise is complicated to review.

Thanks.
Attachment #8440633 - Flags: review?(francisco) → review-
Attachment #8440633 - Attachment is obsolete: true
Attached file PR review: Bug974864 (obsolete) —
Hi Francisco,

I have made new PR from master that include fixed Bug972573.
Please review it.

Thanks.
Attachment #8441903 - Flags: review?(francisco)
Comment on attachment 8441903 [details] [review]
PR review: Bug974864

From a first look the SMS part looks good but I want to test on the device, so flagging myself.
Attachment #8441903 - Flags: review?(felash)
Comment on attachment 8441903 [details] [review]
PR review: Bug974864

r+ to the contacts part, please check the integration tests, they are failing in the test for adding a new contact from sms:

https://travis-ci.org/mozilla-b2g/gaia/jobs/27840635

FAILED TESTS

test_sms_add_contact.py test_sms_add_contact.TestSmsAddContact.test_sms_add_contact

Thanks for the work!
Attachment #8441903 - Flags: review?(francisco) → review+
Francisco, don't we want to use the "supportMms" flag in contacts?
Flags: needinfo?(francisco)
Comment on attachment 8441903 [details] [review]
PR review: Bug974864

r- because:
* we need to use the "supportMms" flag in contacts
Attachment #8441903 - Flags: review?(felash) → review-
(In reply to Julien Wajsberg [:julienw] from comment #8)
> Comment on attachment 8441903 [details] [review]
> PR review: Bug974864
> 
> r- because:
> * we need to use the "supportMms" flag in contacts

Hi Julien,

What is the "supportMms" flag?
I want more details for your r-.

Thanks.
Flags: needinfo?(felash)
Hi Kotaro,

Julien and me have been talking about the patch and we did agree that we won't need the |supportMms| flag (coming from a different bug).

We realised that the work here with the activity is really interesting and we could generalise the activity a bit in order to support more 'things to share' in the future.

Could you change your patch in a way that you return an array of objects,in this case with a single element (just thinking in the future if we implement multiple selection), specifying as well the kind of thing that we are selecting (tel, or email in this case).

Thanks a lot for your work!!
Flags: needinfo?(ko-oki)
Flags: needinfo?(francisco)
Flags: needinfo?(felash)
And please use Settings.supportEmailRecipient in the SMS app (coming in bug 974867) to decide whether you should ask a phone number or both a phone number and an email.
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #6)
> Comment on attachment 8441903 [details] [review]
> PR review: Bug974864
> 
> r+ to the contacts part, please check the integration tests, they are
> failing in the test for adding a new contact from sms:
> 
> https://travis-ci.org/mozilla-b2g/gaia/jobs/27840635
> 
> FAILED TESTS
> 
> test_sms_add_contact.py
> test_sms_add_contact.TestSmsAddContact.test_sms_add_contact
> 
> Thanks for the work!

This FAILED cause test_sms_add_contact.py use contact include tel and email.
When SMS pick this contact, Actionmenu is displayed.
But test_sms_add_contact.py do not have select function for tel or email.
So I want modify test_sms_add_contact.py like below.

# insert contact
 self.contact = MockContact(tel={
  'type': 'Mobile',
  'value': '555%s' % repr(time.time()).replace('.', '')[8:]})
 del self.contact['email'] //Add this line

Can I change this?

(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #10)
> Hi Kotaro,
> 
> Julien and me have been talking about the patch and we did agree that we
> won't need the |supportMms| flag (coming from a different bug).
> 
> We realised that the work here with the activity is really interesting and
> we could generalise the activity a bit in order to support more 'things to
> share' in the future.
> 
> Could you change your patch in a way that you return an array of objects,in
> this case with a single element (just thinking in the future if we implement
> multiple selection), specifying as well the kind of thing that we are
> selecting (tel, or email in this case).
> 
> Thanks a lot for your work!!

I think your order is not need in this bug.
I should change my patch when my code does not work or does not follow mozzila coding policy.
But, now, I think my patch is work fine and follow mozzila coding policy.
So please include your order for another bug.

(In reply to Julien Wajsberg [:julienw] (away June 21 to 30) from comment #11)
> And please use Settings.supportEmailRecipient in the SMS app (coming in bug
> 974867) to decide whether you should ask a phone number or both a phone
> number and an email.

I know bug974867 is not fixed.
So I want to wait the bug fixed and take it.
Flags: needinfo?(francisco)
Flags: needinfo?(felash)
Flags: needinfo?(ko-oki)
Kotaro, sorry for not making this clear enough.

The changes that Francisco and I are asking here are because Web Activities is a public API that can be used by any application in the platform. That's why we don't want to expose anything as a public API, because then we need to support it forever.

What Francisco and I are requesting here is:
* as activity input, add a property, for example called "contactProperties" (Francisco will confirm), that is an array containing the contact properties that needs to be returned. Currently, 'tel' and 'email' only needs to be supported. This array will allow you to decide whether you should display the phone number and/or the email for contacts.
* The SMS app will be able to use the new 'select' activity, and will either pass [ 'tel' ] or [ 'tel, 'email' ] whether Settings.supportEmailRecipient is false/true.

I hope this is clearer for you so that you can move forward.

We understand you have deadlines and some pressure but, again, a public activity API is not a light thing to do, and we need to make it right.

Bug 974867  should be ready soon. The code is ready already but we still work on unit tests, so you should be able to base your work on top of that commit. Please ask if you need instructions about that too.
Flags: needinfo?(felash)
Zac, can you please give some instructions for the python integration test changes in comment 12?
Flags: needinfo?(zcampbell)
(In reply to Kotaro Oki from comment #12)
> (In reply to Francisco Jordano [:arcturus] [:francisco] from comment #6)
> > Comment on attachment 8441903 [details] [review]
> > PR review: Bug974864
> > 
> > r+ to the contacts part, please check the integration tests, they are
> > failing in the test for adding a new contact from sms:
> > 
> > https://travis-ci.org/mozilla-b2g/gaia/jobs/27840635
> > 
> > FAILED TESTS
> > 
> > test_sms_add_contact.py
> > test_sms_add_contact.TestSmsAddContact.test_sms_add_contact
> > 
> > Thanks for the work!
> 
> This FAILED cause test_sms_add_contact.py use contact include tel and email.
> When SMS pick this contact, Actionmenu is displayed.
> But test_sms_add_contact.py do not have select function for tel or email.
> So I want modify test_sms_add_contact.py like below.
> 
> # insert contact
>  self.contact = MockContact(tel={
>   'type': 'Mobile',
>   'value': '555%s' % repr(time.time()).replace('.', '')[8:]})
>  del self.contact['email'] //Add this line
> 
> Can I change this?

Definitely, please go ahead and change it, being sure that doesn't break other tests, if not, we modify the integration test to take into account that has to do another click to select the phone number.

This second option is preferred as we are testing

> 
> (In reply to Francisco Jordano [:arcturus] [:francisco] from comment #10)
> > Hi Kotaro,
> > 
> > Julien and me have been talking about the patch and we did agree that we
> > won't need the |supportMms| flag (coming from a different bug).
> > 
> > We realised that the work here with the activity is really interesting and
> > we could generalise the activity a bit in order to support more 'things to
> > share' in the future.
> > 
> > Could you change your patch in a way that you return an array of objects,in
> > this case with a single element (just thinking in the future if we implement
> > multiple selection), specifying as well the kind of thing that we are
> > selecting (tel, or email in this case).
> > 
> > Thanks a lot for your work!!
> 
> I think your order is not need in this bug.
> I should change my patch when my code does not work or does not follow
> mozzila coding policy.
> But, now, I think my patch is work fine and follow mozzila coding policy.
> So please include your order for another bug.

Kotaro, your work totally agrees with mozilla coding policy, but offering a web activity is like overing a public api of an application.

We have been discussing what's the best public API, to offer to other users. Remember, that web activity could be used by anyone else.

> 
> (In reply to Julien Wajsberg [:julienw] (away June 21 to 30) from comment
> #11)
> > And please use Settings.supportEmailRecipient in the SMS app (coming in bug
> > 974867) to decide whether you should ask a phone number or both a phone
> > number and an email.
> 
> I know bug974867 is not fixed.
> So I want to wait the bug fixed and take it.

Kind regards,
Francisco.
(In reply to Julien Wajsberg [:julienw] (away June 21 to 30) from comment #14)
> Zac, can you please give some instructions for the python integration test
> changes in comment 12?

Yes, the test is failing because of the new Activity prompt (see screenshot at: http://mozilla-releng-blobs.s3.amazonaws.com/blobs/gaia-try/sha512/400806e6903fb5da17577527d755c130fb610350a600cefe4a832a1d19d28ec5e5a08e08cf19c3a1ce6300b4659937cd3c143518986f8c95f1fb523e4760c343)

We should modify the test to follow the flow of selecting a phone number. Most of the test will remain the same.

At line 33 of test_sms_add_contact, after tapping the contact in the picker, we need to return the Activity region:
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/apps/messages/regions/activities.py

In the activities.py we need to add a method called tap_phone_number() which taps the phone number option and then switches back to the Messages app. Then the test can resume untouched.

がんばって!
Flags: needinfo?(zcampbell)
Flags: needinfo?(francisco)
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #15)
> Kotaro, your work totally agrees with mozilla coding policy, but offering a
> web activity is like overing a public api of an application.
> 
> We have been discussing what's the best public API, to offer to other users.
> Remember, that web activity could be used by anyone else.

OK, I understand that I should change the my patch.
But I do not have idea how to change my patch.
Please tell me more detail.

(In reply to Zac C (:zac) from comment #16)
> (In reply to Julien Wajsberg [:julienw] (away June 21 to 30) from comment
> #14)
> > Zac, can you please give some instructions for the python integration test
> > changes in comment 12?
> 
> Yes, the test is failing because of the new Activity prompt (see screenshot
> at:
> http://mozilla-releng-blobs.s3.amazonaws.com/blobs/gaia-try/sha512/
> 400806e6903fb5da17577527d755c130fb610350a600cefe4a832a1d19d28ec5e5a08e08cf19c
> 3a1ce6300b4659937cd3c143518986f8c95f1fb523e4760c343)
> 
> We should modify the test to follow the flow of selecting a phone number.
> Most of the test will remain the same.
> 
> At line 33 of test_sms_add_contact, after tapping the contact in the picker,
> we need to return the Activity region:
> https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/
> gaiatest/apps/messages/regions/activities.py
> 
> In the activities.py we need to add a method called tap_phone_number() which
> taps the phone number option and then switches back to the Messages app.
> Then the test can resume untouched.
> 
> がんばって!

Hi Zac,

I agree with modify the test to follow the flow of selecting a phone number.
But I think it is not in activities.py.
Because "activities.py" is in Message app, however new Activity pompt is in Contacts app.
So, if add a method, it need in Contact-app.py or make new Python file like contact_actionmenu.py in Contacts/regions.
Is it correct?

Finally, Thank you for cheer to me in Japanese!
Flags: needinfo?(zcampbell)
Flags: needinfo?(francisco)
(In reply to Julien Wajsberg [:julienw] (away June 21 to 30) from comment #13)
> Kotaro, sorry for not making this clear enough.
> 
> The changes that Francisco and I are asking here are because Web Activities
> is a public API that can be used by any application in the platform. That's
> why we don't want to expose anything as a public API, because then we need
> to support it forever.
> 
> What Francisco and I are requesting here is:
> * as activity input, add a property, for example called "contactProperties"
> (Francisco will confirm), that is an array containing the contact properties
> that needs to be returned. Currently, 'tel' and 'email' only needs to be
> supported. This array will allow you to decide whether you should display
> the phone number and/or the email for contacts.
> * The SMS app will be able to use the new 'select' activity, and will either
> pass [ 'tel' ] or [ 'tel, 'email' ] whether Settings.supportEmailRecipient
> is false/true.
> 
> I hope this is clearer for you so that you can move forward.
> 
> We understand you have deadlines and some pressure but, again, a public
> activity API is not a light thing to do, and we need to make it right.
> 
> Bug 974867  should be ready soon. The code is ready already but we still
> work on unit tests, so you should be able to base your work on top of that
> commit. Please ask if you need instructions about that too.

I have confirmed and fixed this comment issue.
I want to review for fixed this issue.
Who is the reviewer while Julien is away?
(In reply to Kotaro Oki from comment #17)
> So, if add a method, it need in Contact-app.py or make new Python file like
> contact_actionmenu.py in Contacts/regions.
> Is it correct?
> 

Yes, this is correct, thankyou :)
Flags: needinfo?(zcampbell)
Kotaro, you can ask for review to my self for the contacts part and in the case of SMS you can ask review to Steve Chunk (schung@mozilla.com)

Thanks a lot!
Flags: needinfo?(francisco)
Attached file PR review: Bug974864 (obsolete) —
I make new pull request.
Old pull request is conflict the python code.

New pull request include Comment 18 and fixed ui test.
Please review it.

Finally, I am waiting for how to fix comment 10.
Please more informed for me.

Thanks a lot.
Attachment #8445026 - Flags: review?(zcampbell)
Attachment #8445026 - Flags: review?(schung)
Attachment #8445026 - Flags: review?(francisco)
Flags: needinfo?(francisco)
Attachment #8441903 - Attachment is obsolete: true
(In reply to Kotaro Oki from comment #21)
> Created attachment 8445026 [details] [review]
> PR review: Bug974864
> 
> I make new pull request.
> Old pull request is conflict the python code.
> 
> New pull request include Comment 18 and fixed ui test.
> Please review it.
> 
> Finally, I am waiting for how to fix comment 10.
> Please more informed for me.
> 
> Thanks a lot.

Perfect Kotaro!

You got the essence of what Juliene and myself tried to explain.

Will proceed to the contacts review.

Regards,
Francisco.
Flags: needinfo?(francisco)
Comment on attachment 8445026 [details] [review]
PR review: Bug974864

Thanks a lot for the work here.

r+ to the contacts part, once a small request (done in the github pull request) is done.

Again, thanks for your effort and help here, we really appreciate it!
Attachment #8445026 - Flags: review?(francisco) → review+
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #23)
> Comment on attachment 8445026 [details] [review]
> PR review: Bug974864
> 
> Thanks a lot for the work here.
> 
> r+ to the contacts part, once a small request (done in the github pull
> request) is done.
> 
> Again, thanks for your effort and help here, we really appreciate it!

I have confirmed your comment on Github and refactor my patch.
I think new patch is satisfied your comment.
Please check it.

Thanks.
Attachment #8445026 - Flags: review?(francisco)
Comment on attachment 8445026 [details] [review]
PR review: Bug974864

f+,
I'd prefer the new step to be in its own HTML object but I won't block on it.
Attachment #8445026 - Flags: review?(zcampbell) → feedback+
Comment on attachment 8445026 [details] [review]
PR review: Bug974864

Carrying over the review for the previous patch for the contacts part.
Attachment #8445026 - Flags: review?(francisco) → review+
Kotaro, could you rebase and push the rebased code to the same branch?

With that the PR will get updated automatically.

Thanks folks!
Flags: needinfo?(ko-oki)
I have rebased and fixed Comment#25.
Please review again.

Thanks.
Flags: needinfo?(ko-oki)
Attachment #8445026 - Flags: review?(zcampbell)
Comment on attachment 8445026 [details] [review]
PR review: Bug974864

r+
Attachment #8445026 - Flags: review?(zcampbell) → review+
Comment on attachment 8445026 [details] [review]
PR review: Bug974864

Taking the review back, but won't be able to review before tomorrow.
Attachment #8445026 - Flags: review?(schung) → review?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #30)
> Comment on attachment 8445026 [details] [review]
> PR review: Bug974864
> 
> Taking the review back, but won't be able to review before tomorrow.

Hi Julien,

Did you already review it?
How might it be the result of the review?
Is there any pointing out?

Thanks.
Sorry, I was busy with other things when I came back from holiday...
I'd like to do this today but I'm not sure I'll be able to do it...
Target Milestone: 2.0 S4 (20june) → ---
Comment on attachment 8445026 [details] [review]
PR review: Bug974864

Please fix the small nit and add 2 unit tests.

Thanks and sorry again for the delay !
Attachment #8445026 - Flags: review?(felash) → review-
(In reply to Julien Wajsberg [:julienw] from comment #33)
> Comment on attachment 8445026 [details] [review]
> PR review: Bug974864
> 
> Please fix the small nit and add 2 unit tests.
> 
> Thanks and sorry again for the delay !

Hi Julien,

Thank you for review it.
I have rebased and add unit test.
Please review it.

Thanks.
Attachment #8445026 - Flags: review?(felash)
Comment on attachment 8445026 [details] [review]
PR review: Bug974864

it seems to look fine but I want to check on the device so I need a rebased code, sorry...

I added some minor comments on github.

Also note that the python tests seem to fail: https://travis-ci.org/mozilla-b2g/gaia/jobs/29288857 (line 3325). Can you check it as well?
Attachment #8445026 - Flags: review?(felash) → review-
Attached file PR review2: Bug974864
(In reply to Julien Wajsberg [:julienw] from comment #35)
> Comment on attachment 8445026 [details] [review]
> PR review: Bug974864
> 
> it seems to look fine but I want to check on the device so I need a rebased
> code, sorry...
> 
> I added some minor comments on github.
> 
> Also note that the python tests seem to fail:
> https://travis-ci.org/mozilla-b2g/gaia/jobs/29288857 (line 3325). Can you
> check it as well?

Hi Julien,

I have fixed some comment issue and create new PR.
I tried rebase old PR, but many conflict has happened and crash the branch from my miss operation.
Sorry for inconvenience, please review new PR.
Attachment #8452830 - Flags: review?(felash)
Comment on attachment 8452830 [details] [review]
PR review2: Bug974864

Looks good except that the python tests are failing, so you need to fix this before I give r+.
Attachment #8452830 - Flags: review?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #37)
> Comment on attachment 8452830 [details] [review]
> PR review2: Bug974864
> 
> Looks good except that the python tests are failing, so you need to fix this
> before I give r+.

Hi Julien,

I confirmed python test failed, but I cannot understand why test was failed.
I do not change the python test code from old PR(https://github.com/mozilla-b2g/gaia/pull/20921), and old PR was pass the test(https://travis-ci.org/mozilla-b2g/gaia/jobs/29288857).

Hi Zac,
You say b2g is freezing or crashing in https://github.com/mozilla-b2g/gaia/pull/21511.
Do you have idea for fix the b2g is freezing or crashing?
Flags: needinfo?(zcampbell)
I will run the test locally and debug it for you.
(In reply to Kotaro Oki from comment #38)
> (In reply to Julien Wajsberg [:julienw] from comment #37)
> > Comment on attachment 8452830 [details] [review]
> > PR review2: Bug974864
> > 
> > Looks good except that the python tests are failing, so you need to fix this
> > before I give r+.
> 
> Hi Julien,
> 
> I confirmed python test failed, but I cannot understand why test was failed.
> I do not change the python test code from old
> PR(https://github.com/mozilla-b2g/gaia/pull/20921), and old PR was pass the
> test(https://travis-ci.org/mozilla-b2g/gaia/jobs/29288857).
> 
> Hi Zac,
> You say b2g is freezing or crashing in
> https://github.com/mozilla-b2g/gaia/pull/21511.
> Do you have idea for fix the b2g is freezing or crashing?

I debugged this and the patch isn't working anymore. No context menu is shown.

I also checked this on Flame device and it doesn't work on that either.
Flags: needinfo?(zcampbell)
I think I know what happens: it works only if "Settings.supportEmailRecipient = true" (to be set in the SMS app).

So I'd avise removing these changes to the python tests and keeping them for when we'll enable this property. Maybe file a separate bug for this (I don't think we have one yet) and attach these changes to the bug so that we don't lose them.
(In reply to Julien Wajsberg [:julienw] (PTO Monday 14th July) from comment #41)
> I think I know what happens: it works only if
> "Settings.supportEmailRecipient = true" (to be set in the SMS app).
> 
> So I'd avise removing these changes to the python tests and keeping them for
> when we'll enable this property. Maybe file a separate bug for this (I don't
> think we have one yet) and attach these changes to the bug so that we don't
> lose them.

Hi Julien, Zac,

I'm sorry for the mishap.
I was forgetting the flag that default is "false".
Comment 41 is answer for b2g freeze.
I have confirmed if the flag is true, test is pass in my local.
Then, I have removed to modified the python test and make new file include my modified test that is not work to default.
Please review it.

Thanks.
Attachment #8452830 - Flags: review?(zcampbell)
Attachment #8452830 - Flags: review?(felash)
Comment on attachment 8452830 [details] [review]
PR review2: Bug974864

r-, just remove the unused Python test. There's no point putting in a disabled test. We can write it again later if we need to.
Attachment #8452830 - Flags: review?(zcampbell) → review-
(In reply to Zac C (:zac) from comment #43)
> Comment on attachment 8452830 [details] [review]
> PR review2: Bug974864
> 
> r-, just remove the unused Python test. There's no point putting in a
> disabled test. We can write it again later if we need to.

Hi Zac,

I got it.
I have removed my modified python test.

Hi Julien,

I have pushed it.
Please check it.

Thanks.
Comment on attachment 8452830 [details] [review]
PR review2: Bug974864

(resetting r flags; we don't need a review from Zac now that you don't change the python tests)
Attachment #8452830 - Flags: review-
Comment on attachment 8452830 [details] [review]
PR review2: Bug974864

As discussed on IRC, I'd like a final stamp from Francisco too.
Attachment #8452830 - Flags: review?(francisco)
Attachment #8445026 - Attachment is obsolete: true
Comment on attachment 8452830 [details] [review]
PR review2: Bug974864

It's r=me for the SMS code. Thanks for this work!

Please squash and add "r=julien r=francisco" (or "r=francisco,julien") in the commit log and request checkin once Francisco reviews the patch. Alternatively you can NI me and I can do this work for you, but this will take longer ;)
Attachment #8452830 - Flags: review?(felash) → review+
(In reply to Julien Wajsberg [:julienw] (PTO Monday 14th July) from comment #47)
> Comment on attachment 8452830 [details] [review]
> PR review2: Bug974864
> 
> It's r=me for the SMS code. Thanks for this work!
> 
> Please squash and add "r=julien r=francisco" (or "r=francisco,julien") in
> the commit log and request checkin once Francisco reviews the patch.
> Alternatively you can NI me and I can do this work for you, but this will
> take longer ;)

I have done the squash.
I am waiting Francisco's review and marge this.

Thanks.
Comment on attachment 8452830 [details] [review]
PR review2: Bug974864

Just test everything and working ok (I forgot to enable the setting in sms ;))

r+, waiting for gaia-try to be green:

https://tbpl.mozilla.org/?rev=fc8100f1fcdc3a1d4a47ea90404c9c03325b479a&tree=Gaia-Try

I restarted the ingretaion tests, were failing in a notification test.

Thanks for your work!
Attachment #8452830 - Flags: review?(francisco) → review+
Yeah, the notification test was fixed 2 days ago, it's unrelated; it means the commit is not properly rebased but it should be ok.

Thanks !

master: 3a6bc02d3218185240847e433683ccef285188ad
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
[Blocking Requested - why for this release]:
Nominating this for v2.0, as desired on a 2.0 product.
blocking-b2g: --- → 2.0?
ni? Wayne on how we should be treating these late requests for 2.0.  Wayne, can you drive this bug offline?
Flags: needinfo?(wchang)
From a thread with Wayne and Lucas I can confirm that it is too late to accept this new feature work in 2.0. If this work is required for partner, it will need to be cherry picked off of the 2.1 branch.
blocking-b2g: 2.0? → ---
Flags: needinfo?(wchang)
set partner flag requested by partner
Group: kddi-confidential
Group: kddi-confidential
You need to log in before you can comment on or make changes to this bug.