Closed Bug 974897 Opened 7 years ago Closed 7 years ago

|make test-integration APP=< . . . >| doesn't run because it doesn't generate a good profile

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S2 (28feb)

People

(Reporter: rik, Assigned: daleharvey)

References

Details

(Keywords: regression, Whiteboard: [systemsfe], [p=3])

Attachments

(1 file)

Steps To Reproduce:
rm -rf profile-test
make test-integration APP=email

Workaround:
rm -rf profile-test
make test-integration
Ctrl-C when the tests start running (aka a good profile was generated)
make test-integration APP=email
Summary: |make test-integration APP=email| doesn't run because it doesn't generate a good profile → |make test-integration APP=< . . . >| doesn't run because it doesn't generate a good profile
QA Contact: yurenju.mozilla
Assignee: nobody → yurenju.mozilla
QA Contact: yurenju.mozilla
bisect done, root cause is gaia-marionette modification.

0327274616fb442de9b1146e2fb5a901d3d45d81 is the first bad commit
commit 0327274616fb442de9b1146e2fb5a901d3d45d81
Author: Dale Harvey <dale@arandomurl.com>
Date:   Fri Jan 31 11:19:21 2014 +0000

    Bug 966215 - Allow make test-integration to specify TEST_FILES. r=gaye

:100644 100644 591d426f574f4f2170e2ab274c0ead104f341157 c853f11097ced782e13c5f43088bad300fce848e M  Makefile
:100644 100644 c36e9dcb56e3b6007f65d166402358570d8812d7 cb6a7b8b94594008b728ac1943b8b27fabe7e5cc M  README.md
:040000 040000 7ae1b9e692d449dc63158d23dee18d49442a29ed e2489909887e971ab41683fb967dfb9d9730a097 M  bin
Dale, could you help on this?
Flags: needinfo?(dale)
Assignee: yurenju.mozilla → nobody
Depends on: 966215
Keywords: regression
Before the commit , the profile-test contains all the apps, but now we only have APP=TARGET_APP.
Most of failed tests are trying to access another app inside TARGET_APP, I believe that's the reason.
Theres 2 bugs here, BUILD_APP_NAME shouldnt be modified if we are doing test-integration, sorry that was my bad

The other seems to be some regression with passing command line args, looking at it now
Assignee: nobody → dale
Flags: needinfo?(dale)
heh, the email tests were on a travis blacklist which is also set to our local default
I dont think we need a local default, however the way the arguments are passed here means anything else will be messy and complicated

The profile generation was a regression from https://bugzilla.mozilla.org/show_bug.cgi?id=966215, apologies
Attachment #8380785 - Flags: review?(gaye)
Duplicate of this bug: 974881
Attachment #8380785 - Flags: review?(gaye) → review+
I had assumed the travis manifest got set by travis, but that was wrong, added it to the travis script and merged with a green run

https://github.com/mozilla-b2g/gaia/commit/e5cb62e63b3c2fbe326c96f712e36d228cc765ad
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe]
Target Milestone: --- → 1.4 S2 (28feb)
Whiteboard: [systemsfe] → [systemsfe], [p=3]
You need to log in before you can comment on or make changes to this bug.