Closed Bug 974919 Opened 6 years ago Closed 6 years ago

[Camera][gonk-kk] Front-facing camera app crash on Nexus-5

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, blocker)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 975472

People

(Reporter: schiu, Assigned: schiu)

References

Details

On Nexus-5, when switching to front-facing camera(one or multple times), the camera application crashes. Other functions(previewing and still capturing of back-facing camera) are well.
Assignee: nobody → schiu
in Bug#959505, Vicent Liu mentioned:

I can reproduce the issue. From the gdb tracking, it fails on a callback function.

Breakpoint 1, mozilla::DOMCameraControlListener::Callback::RunCallback (this=0xb2b5f880, aDOMCameraControl=0xb33a1460) at ../../../gecko/dom/camera/DOMCameraControlListener.cpp:306
306	      switch (mError) {

The message in mError shows 

(gdb) p mError
$1 = mozilla::CameraControlListener::kErrorSetThumbnailSizeFailed

I also attach a file for the message of aDOMCameraControl.

Hi Michael,

Does the kErrorSetThumbnailSizeFailed can be a clue to find out the problem from the driver side?
Change to correct component.
Component: General → Gaia::Camera
A set of patches landed last Wednesday night to address a number of regressions introduced by bug 909542. Please confirm whether or not this crash still happens with those patches included.
(In reply to Mike Habicher [:mikeh] from comment #3)
> A set of patches landed last Wednesday night to address a number of
> regressions introduced by bug 909542. Please confirm whether or not this
> crash still happens with those patches included.

I can confirm that the crash still happens with the patch of bug 909542. I would try to remove it to verify.
After adding the patch of bug 975472, the crash never happens.
Depends on: 975472
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 975472
You need to log in before you can comment on or make changes to this bug.