Closed Bug 975091 Opened 6 years ago Closed 6 years ago

Extra padding on some list item titles

Categories

(Firefox for Android :: Awesomescreen, defect, P1)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- unaffected
firefox30 --- verified
firefox31 --- verified
fennec 30+ ---

People

(Reporter: Margaret, Assigned: lucasr)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

See item at the bottom of the screenshot. Lucas, do you know what could be causing this?
Flags: needinfo?(lucasr.at.mozilla)
Some bad interaction between view recycling and linear layouts with layout_weight I guess. Is it easy to reproduce?
Flags: needinfo?(lucasr.at.mozilla)
Comment on attachment 8394244 [details] [diff] [review]
Use wrap_content height params in PanelArticleItem (r=margaret)

Using fill_content with layout_weight was getting ListView all confused. Just wrap content and use center_vertical gravity in the title/description container.
Attachment #8394244 - Flags: review?(margaret.leibovic)
Attachment #8394244 - Flags: review?(margaret.leibovic) → review+
Promoting this bug as P1 as it's requirement for RSS panels.
Priority: -- → P1
tracking-fennec: --- → ?
https://hg.mozilla.org/mozilla-central/rev/9b5ee3b24326
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 30+
Comment on attachment 8394244 [details] [diff] [review]
Use wrap_content height params in PanelArticleItem (r=margaret)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new hub APIs in fx30
User impact if declined: dynamic panels can have too much padding
Testing completed (on m-c, etc.): baked on m-c
Risk to taking this patch (and alternatives if risky): low-risk padding tweak
String or IDL/UUID changes made by this patch: none
Attachment #8394244 - Flags: approval-mozilla-aurora?
Attachment #8394244 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8394244 [details] [diff] [review]
Use wrap_content height params in PanelArticleItem (r=margaret)

Lukas and I discussed this on IRC - I missed uplifting this for the merge, which isn't a big deal, but I will need to land it on beta after the merge is finished.
Attachment #8394244 - Flags: approval-mozilla-beta?
Attachment #8394244 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I verified this with Wikipedia and Goal.com panels and looks good, is not reproducible. I used Nightly (2014-05-09) and Galaxy Nexus (Android 4.2.1).
Verified fixed on:
Build: Firefox for Android 30 Beta 4
Device: Alcatel One Touch (Android 4.1.2) 
Add-ons: wikipedia, pocket
Verified fixed on:
Build: Firefox for Android 31.0a2 (2014-05-16)
Device: Alcatel One Touch (Android 4.1.2) 
Add-on: pocket panel
Status: RESOLVED → VERIFIED
Setting P1 hub bugs to block hub v1 EPIC bug (targeting fx30 release).

Filter on epic-hub-bugs.
Blocks: 1014025
You need to log in before you can comment on or make changes to this bug.