Closed Bug 975198 Opened 6 years ago Closed 6 years ago

Globe icon appears when image doesn't load in grid view

Categories

(Firefox for Android :: Awesomescreen, defect, P1)

ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 30

People

(Reporter: Margaret, Assigned: lucasr)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image screenshot
See screenshot. I assume we have something in place to fall back to our default favicon, which we shouldn't do here.

Question is, what should we do? Show a solid color? We'll need to consider the case where the user doesn't have a network connection and can have difficulty loading remote images, since add-ons don't necessarily store local images.
I think it might be best to leave it blank. We start with that pale blue and then fade the image in when it loads. So the placeholder should probably just be that blue colour.
Comment on attachment 8380556 [details] [diff] [review]
Don't use default favicon as placeholder in PanelItemView (r=margaret)

Leftover from the PanelItemView work in bug 966022. Ian, what's the placeholder for the article view (the one used for RSS)?
Attachment #8380556 - Flags: review?(margaret.leibovic)
Flags: needinfo?(ibarlow)
Hm good question. Don't show the row?
Flags: needinfo?(ibarlow)
Attachment #8380556 - Flags: review?(margaret.leibovic) → review+
Assignee: nobody → lucasr.at.mozilla
https://hg.mozilla.org/mozilla-central/rev/59b615846cf2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Setting P1 hub bugs to block hub v1 EPIC bug (targeting fx30 release).

Filter on epic-hub-bugs.
Blocks: 1014025
You need to log in before you can comment on or make changes to this bug.