Closing Mail window hangs Mozilla

RESOLVED DUPLICATE of bug 76686

Status

MailNews Core
Backend
--
critical
RESOLVED DUPLICATE of bug 76686
17 years ago
9 years ago

People

(Reporter: Trieu Truong, Assigned: Scott MacGregor)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3+)
Gecko/20010829
BuildID:    2001082909

Upon closing my Mail & News window, Mozilla hangs while returning focus to the
browser window.

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla browser window only.
2. Open Mail & News.
3. Close Mail & News window.

Actual Results:  Mail & News window closes, but Mozilla then hangs.

Expected Results:  Mail & News should close, returning focus to Mozilla browser
window, and everything should be happy.

This only started occuring with the last couple of nightly builds.

Comment 1

16 years ago
I see this one sometimes, but only occasionally, not reproducibly.

Comment 2

16 years ago
Unfortunately, it happens every time I open and then close the mail windows. It
does not happen when using a newly created profile.

For the problematic profile, there are a number of POP3, IMAP, as well as
netscape web mail accounts. (my netscape6 and mozilla share the same profile).

any idea on the problem?
(Reporter)

Comment 3

16 years ago
I was afraid that might be the case.  I'm only using IMAP.  I tried cleaning 
out a bunch of stored IMAP mail and other preference files, but to no avail.

Comment 4

16 years ago
I tried to make the following changes and it is solved:

change the IMAP mail server setting FROM:
"When I delete a message: Mark it as delete"
TO
"When I delete a message: Move it to the Trash folder"

Other setting is:
Use SSL (unchecked)
Check for new mail at startup (checked)
Check for new message every 10 mins (checked)
Clean up inbox on exit (checked)
Empty trash on exit (checked)
(Reporter)

Comment 5

16 years ago
Ah, that worked well.  I had my setting on "Remove it immediately."

Thanks!

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

16 years ago
Possibly related to bug 76686 ?

Comment 7

16 years ago
I have also experienced this bug (0.9.6, 2001112009, Windows 2000 and NT4); it's
intermittent and I haven't been able to consistently reproduce it, but it
happens perhaps 50-70% of the time when I close a Mail and News window.
As other people have mentioned in this and bug 76686 (almost certainly
describing the same problem, IMO), I have a couple of accounts that I read with
IMAP; my settings are
[ ] Use secure connection (SSL)
[X] Check for new mail at startup
[X] Check for new messages every [5] minutes
When I delete a message [Remove it immediately]
[X] Clean up ("Expunge") Inbox on exit
[ ] Empty Trash on exit

Comment 8

16 years ago
Further to my last comment, just had it happen again - closed Mail window, my
remaining open (maximised) browser window hung. This is in 0.9.6 under Win2000.

Eventually the window re-drew itself, after I right clicked on taskbar icon
several times and clicked 'Close' on the resulting context menu, however once
window had redrawn context menu would no longer appear (it drew and parts of it
remained visible in the browser window, but it was no longer 'there' - like it
dissapeared immediately). The few times I managed to click 'Close' on the
context menu had no effect other than to close the context menu (part of which
remained drawn in the window, where they overlapped), neither did clicking the
'X' in to top right of the window (the title bar, etc. remained visible throughout).

CPU usage throughout was 0-1% and Quick Launch icon in system tray remained
responsive to right-clicks.

Comment 9

16 years ago
I'm *still* getting this on W2K 2002041003, even though I've changed my settings
(see comment 7) for 'When I delete a message' to 'Move it to the Trash folder'
(so the workaround in comment 4 doesn't work!).

Nominating for 1.0 (although it might be too late for that!), also adding hang
keyword.
Keywords: hang, mozilla1.0

Comment 10

16 years ago
I have 2 computers with two times RC1 installed. I use 2 Imap accounts. One
computer uses Windows XP, the other 2000. With 2000 the problem doesn't occur,
with XP it does (not allways, but often). The XP machine is a laptop with
dial-up connection, the other a desktop with DSL. To be sure, I twice installed
a clean copy of RC1, with exactly the same account-settings. It still occured.
Maybe it has something to do with losing the connection to the Imap-server. I
think it happens more often when I disconnect the modem, without telling Mozilla
to go offline. It's a show-stopper imho.

Comment 11

16 years ago
*Still* getting this with RC2 on W2K. However, still haven't been able to spot a
pattern, except that it doesn't happen after I've been using Mozilla for a short
time, only after I've had mail open for a while - in which case I can reproduce
it fairly reliably. It's a show-stopper IMO!

Is there anything useful I can do to find out where it's hung? Any tools I can
use that will record useful data when a hang occurs so a developer can work out
what the problem is?

I'm gonna nominate for RC3 (bug 143200), see if that produces some action - this
bug has been open for nearly 9 months!

Comment 12

16 years ago
i am getting a similar problem on w2k sp2 with mozilla1 RC2..  everytime i open
Mail & News and close it. i can never open Mail & News again(i got error just
nothing happen, with task manager i see a new mozilla process appear and die
right away.). i can, however, open task manager and kill the remaining mozilla
process (i don't have quick launch on. it don't suppose to have a mozilla
process remaining after i close Mail & New) and it will work again.

i am using Mail & News for two IMAP account only

Comment 13

16 years ago
Another installment in this saga... I seem only to be able to get this bug to
occur when I'm connected to the internet. If I disconnect my modem *then* close
the mail window, it doesn't happen.  This is only based on a few tries, but can
anyone else confirm this?

If this *is* the case, does unchecking 'Clean up ("expunge") Inbox on exit' have
any effect? (I will test this myself over the next few days).

Also, nominating for 1.1, although without a reproducible testcase I doubt it
will get attention.
Keywords: mozilla1.1

Comment 14

16 years ago

*** This bug has been marked as a duplicate of 76686 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.