Closed Bug 975280 Opened 8 years ago Closed 8 years ago

[Sora][Browser]the String in the interface is garbled

Categories

(Web Compatibility :: Mobile, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sync-1, Unassigned)

References

()

Details

Attachments

(2 files)

Mozilla build ID: 20140208004002
 Created an attachment (id=636902)
 picture
 
 DEFECT DESCRIPTION:
 the String in the interface is garbled.phenomenon of Beetle lite FF and soul3.5 FF is the same
 REPRODUCING PROCEDURES:
 1.lanuch"http://eclass.taksun.edu.hk"
 2.the pop up message display abnormally,the String is garbled->KO 
 EXPECTED BEHAVIOUR:
 the pop up message display normally
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 100%
 
 For FT PR, Please list reference mobile's behavior:
Attached image picture
Attached image right picture
Component: Gaia::Browser → Mobile
Product: Firefox OS → Tech Evangelism
This works for me in a Firefox OS 1.4 build. 
This JavaScript is inline in a page that is sent as 

Content-Type: text/html

with no meta charset or other charset-identifying information, so the browser must guess encoding. On Desktop this needs "View > Encoding > Auto-detect > Chinese" enabled to show correctly (although most of the text on the page is inside graphics, so it's only the TITLE bar and this alert() box that show the problem)

I will close this as WFM because it works for me in Firefox OS 1.4 - perhaps there was some fix improving encoding guesswork along the way.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.