Closed Bug 975293 Opened 7 years ago Closed 7 years ago

[DSDS] Once change either SIM 1 or SIM 2 PIN code, user cannot access "Change PIN" of SIM 2 anymore until close Settings app first.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T verified, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S6 (25apr)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- verified
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: echu, Assigned: dwi2)

Details

(Whiteboard: dsdsrun1.4)

Attachments

(3 files)

Once change either SIM 1 or SIM 2 PIN code, user cannot access "Change PIN" of SIM 2 anymore until close Settings app first. It's like touching events get wrong that when I press "Change PIN" under SIM 2, it actually highlights "SIM 2 PIN" area and open disable PIN page.

* Build Number  
Fugu
Gaia      35365feace970bfc51276428f40a477c9c86b7bb
Gecko     048505064d4b8779cd17c820cebb377e0716ef16
BuildID   20140221061554
Version   30.0a1

* Reproduce Steps
1. Enable both SIM cards PIN.
2. Change SIM 1 PIN code. 
3. After code changed successfully, try to open "Change PIN" item below "SIM 2 PIN"

* Expected Result
Modifying SIM 2 PIN page will show.

* Actual Result
Instead it highlights SIM 2 PIN area above and opens enter PIN page for user to disable SIM 2 PIN.

* Occurrence rate
100%
Recover way is to close Settings app from application running list.
Plus this bug for v1.4 since it affects the work in DSDS bug 948584.

EJ,

Mind if you can take this bug since it is must-have DSDS work in v1.4.
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(ejchen)
Assignee: nobody → ejchen
Flags: needinfo?(ejchen)
Target Milestone: --- → 1.4 S3 (14mar)
Hi EJ,

I found that latest build has no such bug now, but if you've found something odd still, please let me know or I'll close the bug.

Fugu (+ latest base image)
Gaia      90673159ea569170109678646b01349620b5a941
Gecko     e8b0013422e7cdc7d0d23d3ed99c47bd0fe88d72
BuildID   20140227075828
Version   30.0a1
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
(In reply to Enpei from comment #3)
> Hi EJ,
> 
> I found that latest build has no such bug now, but if you've found something
> odd still, please let me know or I'll close the bug.
> 
> Fugu (+ latest base image)
> Gaia      90673159ea569170109678646b01349620b5a941
> Gecko     e8b0013422e7cdc7d0d23d3ed99c47bd0fe88d72
> BuildID   20140227075828
> Version   30.0a1

Reproduce on Tarako.Couldn't change SIM2 PIN repeatedly.
The STR:
1,Enable the SIM2 PIN
2,Click "Change PIN",and change the SIM2 PIN
3,Click "Change PIN" once again.
In step 3,there is no response at all.
Attached patch toaster.patchSplinter Review
The patch is for this issue.And the error is:
E GeckoConsole: [JavaScript Error: "TypeError: this._containerElement is undefined" {file: "app://settings.gaiamobile.org/shared/js/toaster.js" line: 53}]

Hi,Tzu-Lin 
    Could you help me to review this patch? Thank you!
Flags: needinfo?(tzhuang)
Attachment #8403701 - Flags: review?(tzhuang)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
v1.3t major bug.
Comment on attachment 8403701 [details] [diff] [review]
toaster.patch

Review of attachment 8403701 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Yang Zhao,

There is a problem with the patch. You need to take care of it when removing event handler.
So instead of the patch, I think it would be better to remove 'this' in _onTransitionEnd(), since Toaster is static.

I'll r cancel it and make a PR for it. Thanks for your finding
Attachment #8403701 - Flags: review?(tzhuang)
Assignee: ejchen → tzhuang
Flags: needinfo?(tzhuang)
Hi Arthur,

Could you help to review the patch? Or transfer to others since it is an one. Thanks a lot
Attachment #8403911 - Flags: review?(arthur.chen)
(In reply to Tzu-Lin Huang [:dwi2][:tzhuang] from comment #8)
> Created attachment 8403911 [details] [review]
> pull request against master
> 
> Hi Arthur,
> 
> Could you help to review the patch? Or transfer to others since it is an
an urgent one, thanks again
> one. Thanks a lot
Tarako needs it. 1.3T+
blocking-b2g: 1.4+ → 1.3T+
Comment on attachment 8403911 [details] [review]
pull request against master

Thanks for the patch. It looks good to me. Could you add a test in simcard_lock_test.js for the sim card index case?
Attachment #8403911 - Flags: review?(arthur.chen)
Comment on attachment 8403911 [details] [review]
pull request against master

Hi Arthur,

Unit test included. Please help to review it again. Thanks
Attachment #8403911 - Flags: review?(arthur.chen)
Comment on attachment 8403911 [details] [review]
pull request against master

r=me, thank you! Please create a pull request against v1.3t before merging to the branch.
Attachment #8403911 - Flags: review?(arthur.chen) → review+
landed on master 
https://github.com/mozilla-b2g/gaia/commit/5827cb13b1a033141ce539e8fbd44cd0bf16593d

Also I confirmed that the PR can be cherry-pick to v1.3t without any conflict, so I'll just spare PR to v1.3t
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
(In reply to Tzu-Lin Huang [:dwi2][:tzhuang] from comment #15)
> Travis is green against v1.3t
forgot to paste the link 
https://travis-ci.org/mozilla-b2g/gaia/builds/22923490
> 
> uplift to v1.3t
> https://github.com/mozilla-b2g/gaia/commit/
> cbbfb52a411903d37e59ab3ce0a4994b405dfa66
Comment on attachment 8403911 [details] [review]
pull request against master

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Users are unable to change SIM 2 PIN more than once
[Testing completed]: yes, and one more test for SIM index included
[Risk to taking this patch] (and alternatives if risky): No
[String changes made]: No
Attachment #8403911 - Flags: approval-gaia-v1.4?
Comment on attachment 8403911 [details] [review]
pull request against master

Taking for 1.4 given user impact. This is beyond the date but considering the user impact being profound taking it for 1.4
Attachment #8403911 - Flags: approval-gaia-v1.4? → approval-gaia-v1.4+
Verified following STR from Comment 0 on 1.3T build does not reproduce reported issue. Modifying SIM 2 PIN page displays each time. 

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140604014021
Gaia: 41a763154fbac34bef6baf17a201e50f52f2b72a
Gecko: fed0b4e6da6c
Version: 28.1
Firmware Version: sp6821a-gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
You need to log in before you can comment on or make changes to this bug.