image dlog--default image size isn't loaded into h/w fields

VERIFIED FIXED in M18

Status

()

Core
Editor
P4
normal
VERIFIED FIXED
19 years ago
16 years ago

People

(Reporter: Kathleen Brade, Assigned: Charles Manske)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][p:4])

(Reporter)

Description

19 years ago
in the image dialog, the height and width are not pre-loaded when the dialog is
initially opened
(Reporter)

Updated

18 years ago
Target Milestone: M10 → M11
(Reporter)

Comment 1

18 years ago
missing JS api from lib image; M11
(Reporter)

Updated

18 years ago
Depends on: 13718
(Reporter)

Updated

18 years ago
Target Milestone: M11 → M15
(Reporter)

Comment 2

18 years ago
M15 (post-beta)
(Reporter)

Comment 3

18 years ago
push off to M16 since pnunn hasn't checked in the fixes yet for #13718 (currently 
set for M17).
Target Milestone: M15 → M16
(Reporter)

Updated

18 years ago
Target Milestone: M16 → M17

Comment 4

18 years ago
Kathy:
are you monitoring bug#13718? I've been waiting for your approval
on the code diffs I sent you.

-P
(Reporter)

Updated

18 years ago
Keywords: correctness, nsbeta3

Comment 5

18 years ago
setting milestone
Target Milestone: M17 → M18
(Reporter)

Comment 6

18 years ago
*** Bug 46081 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
setting to nsbeta3+
Whiteboard: nsbeta3+

Comment 8

18 years ago
adding brackets to status whiteboard
Whiteboard: nsbeta3+ → [nsbeta3+]
(Reporter)

Comment 9

18 years ago
reassign this to cmanske since I'll be going on sabbatical.  Right now we are 
waiting for an API from Pam so we can get the dimensions (bug #13718).
Assignee: brade → cmanske
Status: ASSIGNED → NEW
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 10

18 years ago
Pam: Do we have a method to get image size yet?
Whiteboard: [nsbeta3+] → [nsbeta3+] [p:4]
(Assignee)

Comment 11

17 years ago
Beppe: Please help push on whomever is necessary to make 13718 nsbeta3+ so we
can get this from Pam!
(Assignee)

Comment 12

17 years ago
changing priority.
Priority: P3 → P4

Comment 13

17 years ago
Per PDT, reducing to beta2-minus.   Too many bugs... too little time... we have
to get the deadly bugs more visible.
Whiteboard: [nsbeta3+] [p:4] → [nsbeta3-] [p:4] [minus]

Comment 14

17 years ago
no, back on the radar
Whiteboard: [nsbeta3-] [p:4] [minus] → [nsbeta3+] [p:4] [minus]
(Assignee)

Comment 15

17 years ago
Pam Nunn is very close to done with the required work for 13718, so this is
on track. Note that editor work is trivial once we have an interface to get
the intrinsic size data from the image.
(Assignee)

Comment 16

17 years ago
Still waiting for interface work (13718) to be finished
Whiteboard: [nsbeta3+] [p:4] [minus] → [nsbeta3+] [p:4][blocked]

Comment 17

17 years ago
removing blocked -- 13718 is now fixed
Whiteboard: [nsbeta3+] [p:4][blocked] → [nsbeta3+][p:4]
(Assignee)

Comment 18

17 years ago
Yippy! It works great. All related work for the Image Properties Dialog is
completed and awaiting review to checkin.

Comment 19

17 years ago
yahooooooooooooooooo!
-p
(Assignee)

Comment 20

17 years ago
checked in 9/11
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

17 years ago
Feature notes for testing:
When you choose an image from a filepicker, or leave the source editbox after 
typing a url, or using the dialog with an existing image in the page, that
image is loaded into a new "preview window" in the dialog. This is done on a
timer so we continue to try loading the header to get the size info. The 
preview image is scaled to the size of the preview window if it is larger 
(preview size is 80 x 50).
If the image file doesn't exist or the user is offline (thus a remote image 
can't be loaded), we stop trying to load after 1 minute. In that case, the 
"Width" and "Height" editboxes should be empty (not "0").
Once the image is found, the image appears and its actual width and height are 
reported. If the "actual size" radio button is checked (assuming dialog is in 
expanded mode), those size values are written to the width and height editboxes 
to become the starting values when the user chooses "Custom Size" or the values
that should show when user clicks on "Actual Size" radio button.
Note that "Actual Size" was judged to be better than "Original Size" for this
radio button.

Comment 22

17 years ago
verified in 9/12 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.