Move more Mochitests to manifests

RESOLVED FIXED in mozilla30

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: ted, Assigned: ted)

Tracking

unspecified
mozilla30
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This batch includes a bunch of stuff that bug 939080 made possible
Blocks: 920185
Depends on: 939080
Duplicate of this bug: 975454
Comment on attachment 8379815 [details] [diff] [review]
Move more Mochitests to manifests

Review of attachment 8379815 [details] [diff] [review]:
-----------------------------------------------------------------

not enough here to r-, overall this is great stuff!

::: accessible/tests/mochitest/a11y.ini
@@ +1,3 @@
>  [DEFAULT]
>  support-files =
> +  ../../../content/media/test/bug461281.ogg

it would be so nice to have these files just shared and referenced from the tests via http://mochi.test:8888/shared/bug461281.ogg

on a more actionable note, if this file moves to a different directory, will the build fail?

::: dom/devicestorage/ipc/Makefile.in
@@ -1,5 @@
> -# This Source Code Form is subject to the terms of the Mozilla Public
> -# License, v. 2.0. If a copy of the MPL was not distributed with this file,
> -# You can obtain one at http://mozilla.org/MPL/2.0/.
> -
> -MOCHITEST_FILES := ../test/devicestorage_common.js

I can't find the mochitest.ini where you added this file

::: layout/style/test/Makefile.in
@@ +20,5 @@
>  	./host_ListCSSProperties$(HOST_BIN_SUFFIX) > $@
>  	cat $(srcdir)/css_properties_like_longhand.js >> $@
>  
> +GARBAGE += css_properties.jsm
> +MOCHITEST_FILES += css_properties.js

did you forget this?

::: layout/style/test/mochitest.ini
@@ +27,5 @@
>    visited_image_loading.sjs
>    visited-lying-inner.html
>    visited-pref-iframe.html
>    xbl_bindings.xml
> +generated-files = css_properties.js

is 'generated-files' a valid property here?
Attachment #8379815 - Flags: review?(jmaher) → review+
(In reply to Joel Maher (:jmaher) from comment #3)
> it would be so nice to have these files just shared and referenced from the
> tests via http://mochi.test:8888/shared/bug461281.ogg

Fully agree, but this is taking long enough as-is, I didn't want to add additional effort by changing tests.


> on a more actionable note, if this file moves to a different directory, will
> the build fail?

I will write a test for this to sanity check.

> ::: dom/devicestorage/ipc/Makefile.in
> > -MOCHITEST_FILES := ../test/devicestorage_common.js
> 
> I can't find the mochitest.ini where you added this file

This had been previously added to a manifest:
http://mxr.mozilla.org/mozilla-central/source/dom/devicestorage/ipc/mochitest.ini?force=1#1

> ::: layout/style/test/Makefile.in
> > +MOCHITEST_FILES += css_properties.js
> 
> did you forget this?

No, because this file is generated by the build it can't move to the manifest yet. We'll need to add more capability to moz.build first. I started hacking on bug 883954 to that end.

> ::: layout/style/test/mochitest.ini
> > +generated-files = css_properties.js
> 
> is 'generated-files' a valid property here?

Yes. It doesn't do much of use, it just tells the manifest installation code to not worry if it can't find that file for copying.
all sounds good, I like the sound of a new unit test :)
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #4)
> > on a more actionable note, if this file moves to a different directory, will
> > the build fail?
> 
> I will write a test for this to sanity check.

For reference: this will fail if the file does not exist, and this is already covered by existing tests of the install manifest code.
https://hg.mozilla.org/mozilla-central/rev/c3b332620bb6
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Depends on: 978681
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.