Closed Bug 975808 Opened 6 years ago Closed 6 years ago

When hovering over disabled 'Bookmark this site' button the 'Bookmark menu' button gets hovering state set

Categories

(Firefox :: Theme, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: sjakthol, Assigned: mconley)

References

Details

(Whiteboard: [Australis:P3])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140223123707

Steps to reproduce:

1. Open about:newtab (the 'Bookmark this site' is disabled there).
2. Hover over 'Bookmark this site' button.


Actual results:

The button next to it, 'Show bookmarks' is styled as it was being hovered over.


Expected results:

Nothing. The style of neither button shouldn't have changed.
Component: Untriaged → Theme
See Also: → 975807
Whiteboard: [Australis:P3]
Assignee: nobody → mconley
Attached patch Patch v1Splinter Review
Attachment #8387099 - Flags: review?(jaws)
Attachment #8387099 - Flags: review?(jaws) → review+
https://hg.mozilla.org/integration/fx-team/rev/8187e4139690
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/8187e4139690
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
Comment on attachment 8387099 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

Australis!


User impact if declined: 

Potential for experiencing UI glitch on Linux where hovering a disabled bookmark star causes the hover state of the bookmarks menu button dropmarker to manifest. See screenshot. It just looks sloppy.


Testing completed (on m-c, etc.): 

Plenty of local testing.


Risk to taking this patch (and alternatives if risky): 

Very, very low.


String or IDL/UUID changes made by this patch:

None!
Attachment #8387099 - Flags: approval-mozilla-aurora?
Attachment #8387099 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This issue is no longer reproducible on Firefox 29.0 (Build ID: 20140407135746), Aurora 30 (2014-04-23) and Nightly 31 (2014-04-23), using:
- Ubuntu 12.04 32-bit [1],
- Windows 7 64-bit [2],
- Mac OS X 10.9 [3].
Status: RESOLVED → VERIFIED
Keywords: verifyme
Depends on: 1003931
You need to log in before you can comment on or make changes to this bug.