Closed Bug 976072 Opened 6 years ago Closed 6 years ago

crash in nsXBLPrototypeResources::~nsXBLPrototypeResources() at 0x5a5a5a5a with Yahoo toolbar

Categories

(Core :: XBL, defect, critical)

30 Branch
x86
Linux
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla30
Tracking Status
firefox30 + verified

People

(Reporter: tracy, Assigned: mccr8)

References

Details

(4 keywords)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-ece1e159-1401-4f36-8860-814b12140223.
=============================================================

Startup topcrash that began with Nightly builds of 2014022203

pushlog from the previous Nightly to the 22nd: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7010ab83a06e&tochange=84c9885475e7
Assignee: nobody → continuation
Component: DOM → XBL
Thanks for the CC, Ms2ger.  Seems likely to be a regression from bug 972591.
Blocks: 972591
I looked at 6 reports, and they all had the Yahoo toolbar.  This sounds like a startup crash, so I'll install it and try to reproduce.
Summary: crash in nsXBLPrototypeResources::~nsXBLPrototypeResources() at 0x5a5a5a5a → crash in nsXBLPrototypeResources::~nsXBLPrototypeResources() at 0x5a5a5a5a with Yahoo toolbar
STR: install Yahoo toolbar, open and close the browser a few times (presumably so you start hitting the startup cache).

I landed a backout of part 3 of bug 972591, and confirmed that that fixes the crash.  We still hit the same failure path with the backout, it just doesn't cause a crash.
Keywords: regression
Will go ahead and track this for now so we can keep and eye on it.
Relanded part 3 of bug 972591 and no crashes since then.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
yes, no more crashes since the relanding.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.