The properties positions are moved to the left in the Manifest Editor

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Developer Tools: WebIDE
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: petruta, Assigned: jryans)

Tracking

({regression})

29 Branch
Firefox 30
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 unaffected, firefox29 verified, firefox30 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Reproduces on:
latest Aurora (20140224004003)
 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
latest Nightly (20140224030203)
 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0

Doesn't reproduce on latest Firefox 28 beta 4.

Steps to reproduce:
1. Open about:app-manager page
2. Add a packaged app (download and unzip from https://github.com/mjschranz/webmaker-ffos)
3. Expand a property and move the mouse over the add / remove buttons

Expected results:
The properties are correctly displayed.

Actual results:
The properties values are moved to the left (visual artifact). Expanding another top level object will result in moving it's values to the left while the values for the properties previously expanded will be displayed correctly. Collapsing an object will reproduce the issue again. 

Notes: 
1. The issue also reproduces on Ubuntu 32-bit and Mac OS 10.9
2. The issue is a regression
Regression range:
Last good revision: 3e40f7389d1b (2014-02-02)
First bad revision: 44ba69cacd7e (2014-02-03)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?romchange=3e40f7389d1b&tochan
ge=44ba69cacd7e
Created attachment 8381731 [details] [diff] [review]
Reset icon position in manifest editor on focus
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Attachment #8381731 - Flags: review?(vporof)
Looks like the regression was from bug 952277.
Blocks: 952277
Attachment #8381731 - Flags: review?(vporof) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/4a3f182f06c0
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/4a3f182f06c0
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Comment on attachment 8381731 [details] [diff] [review]
Reset icon position in manifest editor on focus

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 952277
User impact if declined: Focused lines in the manifest editor become indented strangely
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low, CSS changes specific to manifest editor
String or IDL/UUID changes made by this patch: None
Attachment #8381731 - Flags: approval-mozilla-aurora?
status-firefox30: affected → fixed
Attachment #8381731 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/71755e49f3e8
status-firefox29: affected → fixed

Updated

3 years ago
Keywords: verifyme
(Reporter)

Comment 7

3 years ago
Verified as fixed on Firefox 29 beta 2 (20140324101726) and Aurora 30.0a2 (20140324150430) under Mac OS X 10.8.5, Ubuntu 32-bit and Win 7 64-bit.
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
Keywords: verifyme
QA Contact: petruta.rasa
You need to log in before you can comment on or make changes to this bug.