Closed Bug 976489 Opened 6 years ago Closed 6 years ago

Move the customize mode transition to the #navigator-toolbox

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: MattN, Assigned: MattN)

References

Details

(Whiteboard: [Australis:P2][qa-])

Attachments

(1 file)

This would reduce the number of transitions and seems cleaner to me (and thus easier to maintain). Was this considered in bug 962677 or the follow-up bug 967220? Perhaps layout/gfx are smart enough to combine them all into one transition but having it on the container of all of the toolbars seems cleaner and won't interfere with other transitions on the toolbars (see the bottom of bug 963576 comment 19).

compare-talos shows no significant changes on CART: http://compare-talos.mattn.ca/?oldRevs=4c4332cd78a0&newRev=bf012ca44388&submit=true
Conceptually, this sounds like a fine idea, and simplifies the CSS. Going to take this on a test run.
Comment on attachment 8381256 [details] [diff] [review]
v.1 Move transition to navigator-toolbox

LGTM - and also addresses a few pseudoelement glitches during the transition.

Thanks Matt!
Attachment #8381256 - Flags: review?(mconley) → review+
https://hg.mozilla.org/mozilla-central/rev/434a7a69d46f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 30
Comment on attachment 8381256 [details] [diff] [review]
v.1 Move transition to navigator-toolbox

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 962677 changed this
User impact if declined: None.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low risk change to the customization transition
String or IDL/UUID changes made by this patch: None
Attachment #8381256 - Flags: approval-mozilla-aurora?
Attachment #8381256 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [Australis:P2] → [Australis:P2][qa-]
You need to log in before you can comment on or make changes to this bug.