Support dynamic viewport changes

RESOLVED DUPLICATE of bug 976616

Status

()

defect
RESOLVED DUPLICATE of bug 976616
5 years ago
2 months ago

People

(Reporter: miketaylr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

5 years ago
(A clone of 976616 - filed on Firefox for Android)

Certain mobile sites on the web assume that you can dynamically change meta viewport content (and have it actually do something).

Currently we don't support this, but only allow changing the viewport if you append a new meta element with a different value.

See https://miketaylr.com/bzla/viewport-change.html for a test case. 

Expected: Clicking all 4 buttons changes the viewport
Actual: Only the append buttons work
Reporter

Updated

5 years ago
See Also: → 784463
This code actually lives in the platform side of things, in TabChild.cpp.
Component: Gaia::Browser → DOM
OS: Mac OS X → Gonk (Firefox OS)
Product: Firefox OS → Core
Hardware: x86 → All
Reporter

Comment 2

3 years ago
This was fixed for b2g by Bug 976616 as well.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 976616
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.