Closed Bug 976631 Opened 6 years ago Closed 6 years ago

rijndael.c:981: Error: no such instruction: `xgetbv'

Categories

(NSS :: Libraries, defect, P2)

3.15.4
x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: kaie, Assigned: wtc)

References

Details

Attachments

(1 file)

No description provided.
On which platform has this been seen?
I have a CentOS 5.8 VM box with a locally compiled gcc 4.8.2, where this failed.  We're preserving the VM.
Also, for the record, this was with mozilla-release code, version 27.0.1.
Alex, could you please provide:

uname -a

cat /proc/cpuinfo
Blocks: 940794
Alex:

Is this a compilation error, or a runtime error?

I believe this is a compilation error, and it's caused by
the assembler /usr/bin/as being not new enough.

What is the output of "as --version"?
https://hg.mozilla.org/mozilla-central/rev/3b91918ab945
Assignee: nobody → neil
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Carsten Book [:Tomcat] from comment #7)
> https://hg.mozilla.org/mozilla-central/rev/3b91918ab945

Carsten, I think you added this to the wrong bug?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Kai Engert (:kaie) from comment #8)
> (In reply to Carsten Book [:Tomcat] from comment #7)
> > https://hg.mozilla.org/mozilla-central/rev/3b91918ab945
> 
> Carsten, I think you added this to the wrong bug?

thanks kai! the commit message had the wrong bug nummer in it and belong to bug 976613
Status: REOPENED → NEW
(In reply to Carsten Book from comment #9)
> (In reply to Kai Engert from comment #8)
> > (In reply to Carsten Book from comment #7)
> > > https://hg.mozilla.org/mozilla-central/rev/3b91918ab945
> > 
> > Carsten, I think you added this to the wrong bug?
> 
> thanks kai! the commit message had the wrong bug number in it and belongs to
> bug 976613

Sorry, I'm terrible when it comes to typoing bug numbers in checkin comments.
Assignee: neil → nobody
Alex:

I hope this compilation error can be fixed by installing the right
version of the GNU Assembler. If it is difficult, we can look into
emitting the bytes of the xgetbv instruction directly. There is
such code in the Mozilla tree:
http://mxr.mozilla.org/mozilla-central/search?string=TestOsSaveYmm
Assignee: nobody → wtc
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → 3.16
(In reply to Wan-Teh Chang from comment #11)
> I hope this compilation error can be fixed by installing the right
> version of the GNU Assembler. If it is difficult, we can look into
> emitting the bytes of the xgetbv instruction directly. There is
> such code in the Mozilla tree:
> http://mxr.mozilla.org/mozilla-central/search?string=TestOsSaveYmm

It seems like we have the same problem with some installations of VS2010, so I think we should duplicate the TestOsSaveYmm function in NSS and/or NSPR.
(In reply to Wan-Teh Chang from comment #6)
> What is the output of "as --version"?

GNU assembler 2.17.50.0.6-20.el5_8.3 20061020
Also, for the record:  we were successfully able to build on CentOS 6 with devtoolset-2, so we're not blocked by this.
Alex: thanks for the info. Since you have an assembler that supports
the xgetbv instruction, I marked the bug WONTFIX.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WONTFIX
Version: 3.16 → 3.15.4
(In reply to Alex Vincent [:WeirdAl] from comment #13)
> (In reply to Wan-Teh Chang from comment #6)
> > What is the output of "as --version"?
> 
> GNU assembler 2.17.50.0.6-20.el5_8.3 20061020

Alex:

Starting in NSS 3.14.2, NSS requires GNU assembler 2.19 or newer.
The NSS 3.14.2 release notes describe how to get a newer version
of binutils on Red Hat Enterprise Linux 5.x systems:

https://developer.mozilla.org/en-US/docs/NSS/NSS_3.14.2_release_notes

Hopefully that info also applies to CentOS 5.8.
OS: All → Linux
(In reply to Wan-Teh Chang from comment #16)
> Starting in NSS 3.14.2, NSS requires GNU assembler 2.19 or newer.
> The NSS 3.14.2 release notes describe how to get a newer version
> of binutils on Red Hat Enterprise Linux 5.x systems:
> 
> https://developer.mozilla.org/en-US/docs/NSS/NSS_3.14.2_release_notes

Isn't that the kind of thing we have configure.in scripts for???
That's true. In this case, I think the benefit of hardware acceleration
is so high that it is worth forcing the proper version of assembler.

We can, however, have the build system check the GNU assembler version
and fail with a helpful error message. What I want to avoid is for the
build system to silently disable the assembly code.
You need to log in before you can comment on or make changes to this bug.