Closed Bug 977048 Opened 7 years ago Closed 7 years ago

Close icon only works for click-to-play plugins

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set
normal

Tracking

(seamonkey2.24 wontfix, seamonkey2.25 affected, seamonkey2.26 fixed, seamonkey2.27 fixed)

RESOLVED FIXED
seamonkey2.27
Tracking Status
seamonkey2.24 --- wontfix
seamonkey2.25 --- affected
seamonkey2.26 --- fixed
seamonkey2.27 --- fixed

People

(Reporter: neil, Assigned: neil)

Details

Attachments

(1 file)

If you visit a page with a missing or disabled plugin, the placeholder appears, but the icon that hides the placeholder does not function.

This is the SeaMonkey version of Firefox bug 921730.
Attached patch Proposed patchSplinter Review
I renamed the methods because we're no longer limiting this to click-to-play.

I don't know whose review queue is the shortest so pinging several victims...
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8382137 - Flags: review?(philip.chee)
Attachment #8382137 - Flags: review?(iann_bugzilla)
Attachment #8382137 - Flags: review?(bugzilla)
Comment on attachment 8382137 [details] [diff] [review]
Proposed patch

Patch works fine and looks good.
Attachment #8382137 - Flags: review?(philip.chee)
Attachment #8382137 - Flags: review?(iann_bugzilla)
Attachment #8382137 - Flags: review?(bugzilla)
Attachment #8382137 - Flags: review+
Pushed comm-central changeset 2ff64f30b526.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.27
Comment on attachment 8382137 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 921730
User impact if declined: Useless close button on plugin overlays
Testing completed (on m-c, etc.): Already uplifted to comm-aurora
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #8382137 - Flags: approval-comm-beta?
Comment on attachment 8382137 [details] [diff] [review]
Proposed patch

a=me for comm-beta
Attachment #8382137 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.