Closed Bug 977050 Opened 6 years ago Closed 6 years ago

Automate changing end date/time in Calendar

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Android
defect
Not set

Tracking

(feature-b2g:2.1, b2g-v1.1hd affected, b2g-v1.3 affected)

VERIFIED FIXED
2.1 S2 (15aug)
feature-b2g 2.1
Tracking Status
b2g-v1.1hd --- affected
b2g-v1.3 --- affected

People

(Reporter: chiorean.ioana, Assigned: evanxd)

References

Details

(Whiteboard: ux-most-wanted, [priority][tako][2.1-feature-qa+][p=5])

User Story

As a user, when I edit a meeting and change the start time, I want the end time to move accordingly.

Attachments

(2 files, 2 obsolete files)

Device: Geon from Geeksphone
OS: Boot3Gecko 1.3.0.0-prerelease (02/25)
Device2: ZTE Open from Telefonica
OS2: Open_Latam_FFOS_v1.1.0B01

Steps to reproduce:
1. Go to Calendar - add new event
2. Set start time
3. Set end time 
4. Save event
5. Go back to the event and press edit
6. Set start event after end event

Actual results:
- End date doesn't change automatically

Expected Results:
- After step 2 and 6 - end date/time should be automatically set to start date/time

Note 
- please see video: http://www.youtube.com/watch?v=-uTwgErdaOY
Whiteboard: ux-most-wanted
Blocks: 994991
Suggest that the end date-time should always be after the start time (for example; default to 1h long meeting).

Will need UX guidance.
blocking-b2g: --- → backlog
Whiteboard: ux-most-wanted → ux-most-wanted, [priority]
Attaching a draft UX spec to get everyone started.
Duplicate of this bug: 966361
feature-b2g: --- → 2.1
User Story: (updated)
Duplicate of this bug: 885420
Attachment #8419943 - Attachment is obsolete: true
QA Contact: edchen
Assignee: nobody → evanxd
blocking-b2g: backlog → ---
Whiteboard: ux-most-wanted, [priority] → ux-most-wanted, [priority][tako]
Target Milestone: --- → 2.1 S1 (1aug)
Target Milestone: 2.1 S1 (1aug) → 2.1 S2 (15aug)
Attachment #8448478 - Attachment is obsolete: true
QA Whiteboard: [2.1-feature-qa+]
QA Whiteboard: [2.1-feature-qa+] → [COM=Productivity]
QA Whiteboard: [COM=Productivity] → [COM=Gaia::Calendar]
QA Whiteboard: [COM=Gaia::Calendar] → [COM=Gaia::Calendar][2.1-feature-qa+]
Flags: in-moztrap?(edchen)
QA Whiteboard: [COM=Gaia::Calendar][2.1-feature-qa+] → [COM=Gaia::Calendar]
Whiteboard: ux-most-wanted, [priority][tako] → ux-most-wanted, [priority][tako][2.1-feature-qa+]
This patch is just for ui review not code review currently.
Comment on attachment 8470679 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22716

Hi Harly,

Could you help to review the patch?

Thanks.
Attachment #8470679 - Flags: ui-review?(hhsu)
Whiteboard: ux-most-wanted, [priority][tako][2.1-feature-qa+] → ux-most-wanted, [priority][tako][2.1-feature-qa+][p=5]
Comment on attachment 8470679 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22716

Thanks for the nice work, Evan!!
Attachment #8470679 - Flags: ui-review?(hhsu) → ui-review+
Harly, thanks for the review.

ui-review+ commit: https://github.com/evanxd/gaia/commit/c1938e2446575a1977ec085b910d32d013163f81
Comment on attachment 8470679 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22716

Hi Miller,

Could you give me feedback for the patch?
I will add unit/marionette tests later.

Thanks.
Attachment #8470679 - Flags: feedback?(mmedeiros)
Attachment #8470679 - Flags: feedback?(mmedeiros)
Patch looks good to me Evan! we just need some tests to make sure we don't introduce regressions (can be unit or integration, whatever is easier to write).
Comment on attachment 8470679 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22716

Hi Miller,

I updated patch and add marionette tests for it.
Could you help to review it?

Thanks.
Attachment #8470679 - Flags: review?(mmedeiros)
Comment on attachment 8470679 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22716

good work!
Attachment #8470679 - Flags: review?(mmedeiros) → review+
Miller, thanks for the review.
I will land it after the tree is reopened.
master: https://github.com/mozilla-b2g/gaia/commit/e049054e1fc575390315e7323fa5337bdd62d9fe
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Blocks: 1054718
[Environment]
Gaia      3584b2723412ed3299c6761f465885d80651c87e
Gecko     https://hg.mozilla.org/mozilla-central/rev/e7806c9c83f3
BuildID   20140820160201
Version   34.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

[Result]
PASS
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.