Closed Bug 977120 Opened 6 years ago Closed 6 years ago

Enable NetworkGeolocationProvider to collect cellular tower data on Firefox oS

Categories

(Firefox OS Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

RESOLVED FIXED
1.4 S3 (14mar)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed

People

(Reporter: rbarnes, Assigned: dougt)

References

Details

Attachments

(1 file)

Currently, NetworkGeolocationProvider only has access to WiFi information, even though information on visible cell towers is accessible in Firefox OS.  We should include those towers so that they can be used to improve location results.
you'll probably want to start with this so that B2G uses the NetworkLocationProvider:

   https://github.com/dougt/gecko-dev/tree/enable_mls_on_b2g
Duplicate of this bug: 976396
I'm working on a patch.  Should be ready tomorrow once I test.
Assignee: martin.thomson → dougt
blocking-b2g: --- → 1.3T+
Attachment #8388494 - Flags: review?(josh)
fabrice, you will want to add:
     pref("geo.cell.scan", true);


Alternatively, jdm, I could just always try to update cell data on all platforms
Attachment #8388494 - Flags: review?(martin.thomson)
Comment on attachment 8388494 [details] [diff] [review]
0001-Cell-record-support.patch

Review of attachment 8388494 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.  Maybe we want to track this so that we can enable scanning, if there is some way to do that without causing stuff to blow up.
Attachment #8388494 - Flags: review?(martin.thomson) → review+
Attachment #8388494 - Flags: review?(josh) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/20e2ef50fa8b



Fabrice -- you will want to add pref("geo.cell.scan", true); on devices you care about.
https://hg.mozilla.org/mozilla-central/rev/20e2ef50fa8b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S3 (14mar)
Doug, can you rebase on 1.3t ?
Depends on: 978593
No longer depends on: 978593
Hi Ying Xu, heard that you will be doing uplifts to 1.3T branch. After you completed the uplift, can you please set status-b2g-v1.3T to fixed? please let us know if you have problems with it. thanks
Flags: needinfo?(ying.xu)
Depends on: 978593
Flags: needinfo?(ying.xu)
You need to log in before you can comment on or make changes to this bug.