Email address autocomplete doesn't always display match list or displays slowly

VERIFIED DUPLICATE of bug 126480

Status

MailNews Core
Composition
P2
normal
VERIFIED DUPLICATE of bug 126480
17 years ago
4 years ago

People

(Reporter: Adam Masri, Assigned: Joe Hewitt (gone))

Tracking

({pp})

Trunk
mozilla1.0
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need info])

(Reporter)

Description

17 years ago
Platform: PowerBook G3/300/192Mb/25Gb, MacOS X 10.0.4
Fizzilla build: 2001082905

Try the following:

1) Create a new email message.

2) Begin to type the email address of someone in your address book.

What should happen: list of autocomplete addresses should appear almost immediately.

What happens: list takes awhile before it displays, if at all. I've noticed that
sometimes, I have to "coax" it by typing in, then deleting, then typing in a few
more characters before I get the list.

- Adam

Updated

17 years ago
QA Contact: sheelar → nbaca

Updated

16 years ago
Blocks: 63759
Adam, 2 questions:

1) Are you using a LDAP server fr autocompletion?
2) Do you still see this problem using a recent build under MacOS X 10.1 or greater?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 2

16 years ago
Fizzilla Build: 2001121105

1) No.

2) Yes, sometimes. Every so often I'll type in an email address to autocomplete,
and the cursor will just sit there, blinking at me. It doesn't show the drop
down list. Sometimes at this point not even closing the Mail window and
reopening will fix. I have to quit, then reboot. I've also noticed that
sometimes, when this happens, Mozilla crashes on Quit. This is simply not enough
info to go on, and I don't have a set of reproducable steps to force this to occur.

- Adam

Updated

16 years ago
Keywords: nsbeta1
Target Milestone: mozilla1.0 → ---

Comment 3

16 years ago
Discussed in 2/26 bug meeting with Mktg Engineering and PjM.  Decision was to
nsbeta1 plus, make P2, and assign to 1.0.
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 4

16 years ago
Trunk build 2002-02-26-13: Mac 10.1.3

- Local Address Books: I can reproduce the problem. I have a variety of entries
in my address book (PAB and CAB). They include qatest20@netscape.com,,
qatest22@netscape.com, qatest33@netscape.com. In a new message I type "q" and it
autocompletes to "qatest20@netscape.com" and doesn't show the other addresses.
Then I type "qa" and it autocompletes to "qatest33@netscape.com", again never
showing the other addresses. If I backspace and then type "q" then it shows a
drop list of addresses.


- LDAP Directory:Autocomplete appears to be working with LDAP entries because a
drop down list of addresses appear which match the text I have entered in the
address area.

Comment 5

16 years ago
Trunk build 2002-02-27: Mac 10.1.3
Again, I only see a problem on OS/X. If anyone in the triage team sees this 
problem on other operating systems then please give more details so that I can 
try to duplicate.
Keywords: pp

Updated

16 years ago
Keywords: mozilla1.0+
I can reproduce the problem on MacOSX too.

The first time, I type "q" and not drop down menu,
then I type "a",I get a bunch of result starting with "a"
I now type again "q" and I get all the "q" result!

This is only a problem with the dropdown list as event if the menu is not there,
you can still navigate through the result using the Up/Down key.

cc'ing hewitt, should be probably reassign to him...
in autocomple.xml, we correctly call
this.resultsPopup.showPopup(this, -1, -1, "popup", "bottomleft", "topleft");
but nothing appends. Reassign to hewitt.
Assignee: ducarroz → hewitt
Status: ASSIGNED → NEW

Comment 8

16 years ago
ADT triage team needs info: Does this only happen when typing one character, or
is there a reproducible case where typing several characters fails to show the
resulting matches?
Whiteboard: [need info]
(Reporter)

Comment 9

16 years ago
Fizzilla build 0.9.9

The situation happening in comment #4 happens to me. It'll autocomplete to my
own domain, which is really annoying, instead of someone in the addressbook.
Reproducible test case? I'll try to come up with one, but it just randomly does
it. No real rhyme or reason as far as I can tell.

- Adam

Comment 10

16 years ago
Please update this bug with an [adt1] - [adt3] impact rating (or take it off the
list if it doesn't even rate adt3.)  Thanks!

Comment 11

16 years ago
This is very easy to reproduce using Mac 10.1.3 (build 2002-04-05)

1. Create a new profile
2. Configure mail for any type of account
3. Open the Address Book
4. Add 4 cards
- 1st card w/email address: qatest20@netscape.com
- 2nd card w/email address: qatest22@netscape.com
- 3rd card w/email address: qatest32@netscape.com
- 4th card w/email address: qatest33@netscape.com
5. Close the Address Book window
6. Select Compose Button

Actual Results:
a. Type "q" and it autcompletes to qatest32@netscape.com
- backspace to delete "q"
- type "q" again and now a dropdown displays all the qatest addresses 
(qatest32@netscape.com, qatest33@netscape.com, qatest20@netscape.com, 
qatest22@netscape.com).

b. New Compose window and type "qa"
- similar results as "a."

c. New Compose window and type "qatest"
- similar results as "a."

Comment 12

16 years ago
I'm seeing this problem with RC1 on MacOS9.1 as well - this occurs on LDAP
lookups (different issue?).  Like what others have said, you can "coax" it into
working by typing, deleting, typeing, deleting, and eventually it comes up. 
Interesting thing is that once it is up and working, generally it keeps working
until the next restart of the app.
(Assignee)

Comment 13

16 years ago

*** This bug has been marked as a duplicate of 126480 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 14

16 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.