Closed Bug 977215 Opened 6 years ago Closed 6 years ago

[B2G][Homescreen] Icons become unresponsive and only the Marketplace app can be opened

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S2 (28feb)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: tnguyen, Unassigned)

References

Details

(Keywords: regression, smoketest)

Attachments

(1 file, 1 obsolete file)

127.13 KB, text/plain
Details
Attached file logcat (obsolete) —
Description:
Double tapping the home button while an MMS is in the process of sending, will bring the user back to the homescreen. None of the icons on the homescreen are responsive except for Marketplace. The user is still able to navigate the homescreen but unable to open any of the apps.

Repro Steps:
1) Updated Buri to BuildID: 20140226040201
2) Navigate to Messages App
3) Tap on an existing thread (or create a new thread)
4) Tap paper clip icon to attach an image and crop it
5) Tap the "Send" button
6) Immediately after, double tap the home button to return to homescreen while message is sending

Actual Result: 
Homescreen icons can be tapped on and apps can be opened

Expected Result:
Homescreen icons are unresponsive and user is only able to open Marketplace

Environmental Variables:
Device: Buri Master M-C mozRIL
BuildID: 20140226040201
Gaia: 80d6405725788327102cab36e8d8c017cf25fb23
Gecko: 626d99c084cb
Version: 30.0a1
v1.2-device.cfg

Attached: logcat

Note: 

-This issue has been encountered in multiple areas. There was an instance where attempting to delete apps from homescreen lead to an unresponsive homescreen, another when the user was searching E.me when the homescreen became unresponsive, and also when the user opened browser and returning home quickly after. This is currently the best method of reproducing this issue.

-I had to attach an image from gallery, then crop it before being able to start capturing a logcat since the device doesn't allow for the gallery app to be opened while having USB Storage enabled and having a cable plugged in.
Does this reproduce on 1.3?
Keywords: qawanted
This issue does *not* reproduce for me on the 02/27/14 1.3 build on a Buri.

Device: Buri v1.3 MOZ RIL
BuildID: 20140227004003
Gaia: ad504390a7a5f094f8967f80a0f29a1e6552535e
Gecko: 6bd9b70a1b6c
Version: 28.0
Firmware Version: V1.2-device.cfg
Keywords: qawanted
QA Contact: mvaughan
blocking-b2g: --- → 1.4?
This issue started reproducing on the 02/24/14 1.4 build.

The following regression window was found using tinderbox builds:

- Last Working -
Device: Buri v1.4 MOZ RIL
BuildID: 20140224074714
Gaia: 0eadf61ef60f13324fe8290d8c2b516d98230fdc
Gecko: 1422dfcd7fd8
Version: 30.0a1
Firmware Version: V1.2-device.cfg

- First Broken -
Device: Buri v1.4 MOZ RIL
BuildID: 20140224131511
Gaia: e0f39c7179c8b297326c0e2313950610be1f5c52
Gecko: 4b6103d24d1e
Version: 30.0a1
RIL Version:
Firmware Version: V1.2-device.cfg


*This appears to be a gecko issue*

last working gaia/first broken gecko = REPRO
Gaia  0eadf61ef60f13324fe8290d8c2b516d98230fdc
Gecko 4b6103d24d1e

first broken gaia/last working gecko = NO REPRO
Gaia  e0f39c7179c8b297326c0e2313950610be1f5c52
Gecko 1422dfcd7fd8


Push log: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1422dfcd7fd8&tochange=4b6103d24d1e
So whatever regressed here has to be something cross-cutting. Here's the cross-cutting candidates:

* bug 957323
* bug 973842
* bug 903291
Sotaro, I know that bug 957323 is not meant to affect buri (ICS), but can you confirm?
Flags: needinfo?(sotaro.ikeda.g)
Although original STR doesn't state that exactly, this issue is global and happens across the board - within 2 hours of normal device use I hit this issue 5 times in multiple areas - apps become unresponsive requiring Restart to recover. Having said that, adding smoketest keyword here.
Keywords: smoketest
(In reply to Milan Sreckovic [:milan] from comment #5)
> Sotaro, I know that bug 957323 is not meant to affect buri (ICS), but can
> you confirm?

bug 957323 should not affect to ICS, the change affect only to JB and KK. Anyway, I am going to try if I could reproduce the problem.
Flags: needinfo?(sotaro.ikeda.g)
(In reply to Matthew Vaughan from comment #3)
> This issue started reproducing on the 02/24/14 1.4 build.
> 
> The following regression window was found using tinderbox builds:
> 
> - Last Working -
> Device: Buri v1.4 MOZ RIL
> BuildID: 20140224074714
> Gaia: 0eadf61ef60f13324fe8290d8c2b516d98230fdc
> Gecko: 1422dfcd7fd8
> Version: 30.0a1
> Firmware Version: V1.2-device.cfg
> 
> - First Broken -
> Device: Buri v1.4 MOZ RIL
> BuildID: 20140224131511
> Gaia: e0f39c7179c8b297326c0e2313950610be1f5c52
> Gecko: 4b6103d24d1e
> Version: 30.0a1
> RIL Version:
> Firmware Version: V1.2-device.cfg
> 
> 
> *This appears to be a gecko issue*

Is there a reason that this is a gecko issue?
(In reply to Sotaro Ikeda [:sotaro] from comment #8)
> 
> Is there a reason that this is a gecko issue?

For example there is a change around window manager like Bug 973828 .

https://github.com/mozilla-b2g/gaia/pull/16397/files
Duplicate of this bug: 978186
(In reply to Sotaro Ikeda [:sotaro] from comment #9)
> (In reply to Sotaro Ikeda [:sotaro] from comment #8)
> > 
> > Is there a reason that this is a gecko issue?
> 
> For example there is a change around window manager like Bug 973828 .
> 
> https://github.com/mozilla-b2g/gaia/pull/16397/files

Well, the regression range certainly shows it. We swapped the last working & first broken builds & it's showing that this fails in the first broken gecko + last working gaia combination. That usually implies this is a gecko regression.
The logcat here doesn't have console enabled. Please get a new logcat with console enabled.
Keywords: qawanted
Attached file LogCat
(In reply to Jason Smith [:jsmith] from comment #12)
> The logcat here doesn't have console enabled. Please get a new logcat with
> console enabled.

Attached requested logcat with console enabled.
Attachment #8382380 - Attachment is obsolete: true
Keywords: qawanted
Technically we could bisect the range deeper here. Let's bisect using b2g-inbound tinderbox builds.
(In reply to Jason Smith [:jsmith] from comment #14)
> Technically we could bisect the range deeper here. Let's bisect using
> b2g-inbound tinderbox builds.

Use https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/b2g-inbound-hamachi-eng/ specifically.
(In reply to Jason Smith [:jsmith] from comment #14)
> Technically we could bisect the range deeper here. Let's bisect using
> b2g-inbound tinderbox builds.

Deeper regression window:

- Last Working -
Device: Buri v1.4 MOZ RIL
BuildID: 20140223235616
Gaia: 5bbaeb30a48cfbc9bfc6a2eb68d5b30d72601a97
Gecko: 0f682360b9a9
Version: 30.0a1
Firmware Version: V1.2-device.cfg

- First Broken -
Device: Buri v1.4 MOZ RIL
BuildID: 20140224005312
Gaia: 998850755b7b74141f92178a813958d12245b587
Gecko: 6058a0d53426
Version: 30.0a1
Firmware Version: V1.2-device.cfg
The above testing is arguing this is a gecko regression. If that's the case, then bug 903291 is definitely cause here, since the other bug in the push log doesn't seem likely to cause a regression like this.

If the above gaia vs. gecko split wasn't right, then bug 973828 is the cause.
(In reply to Jason Smith [:jsmith] from comment #19)
> The above testing is arguing this is a gecko regression. If that's the case,
> then bug 903291 is definitely cause here, since the other bug in the push
> log doesn't seem likely to cause a regression like this.
> 
> If the above gaia vs. gecko split wasn't right, then bug 973828 is the cause.

last working gaia/first broken gecko = REPRO
Gaia  5bbaeb30a48cfbc9bfc6a2eb68d5b30d72601a97
Gecko 6058a0d53426

first broken gaia/last working gecko = NO REPRO
Gaia  998850755b7b74141f92178a813958d12245b587
Gecko 0f682360b9a9
Okay - we've double checked here. It's confirmed to be bug 903291 then. I'm going to issue a backout on that patch.
Blocks: 903291
Flags: needinfo?(alive)
Fixed via backout of bug 903291.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: 1.4? → 1.4+
This issue is no longer reproducing on the latest Buri Master M-C build.

Environmental Variables:
Device: Buri Master M-C mozRIL
BuildID: 20140303114510
Gaia: dfae3744607257206e37483dc3f431108baf70fb
Gecko: c8bea55437c1
Version: 30.0a1
v1.2-device.cfg
Status: RESOLVED → VERIFIED
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.