[PP] Edit | Wallet | Display Cookies window is blank

VERIFIED WORKSFORME

Status

()

Toolkit
Form Manager
P1
blocker
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: jay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: working on Windows and Mac. gtk problem undiagnosed.)

(Reporter)

Description

19 years ago
Safe Form Fill dialog window is blank....can't test AutoFill

Steps:
1. Goto Edit | Wallet | Samples
2. Click on "here" to prespecify data
3. Goto Amazon.com from Samples page
4. Click Edit | Wallet | Safe Form Fill
5. Window pops up, but does not have any content

Machines and Builds:
Win98 build 1999071310
Linux RH 5.2 build 1999071308
Mac OS 8.5.1 build 1999071309

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
Summary: Edit | Wallet | Safe Form Fill window is blank → Edit | Wallet | Safe Form Fill window is blank

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 9601 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

19 years ago
Blocks: 9798

Updated

19 years ago
No longer blocks: 9798
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 2

19 years ago
This may be a dup of 9601 in some way...but this is happening again with the mac
build 1999071908...so i am reopening this one, since it does not have any
crashes related to it, and the fact that 9601 has been verified fixed. (follow
the same initial steps mentioned to reproduce)

Comment 3

19 years ago
Are you seeing this problem on all platforms or just on the mac?  Also, do you
get a blank window when you do edit/wallet/view-cookies?  I'm asking because I
use the same sort of coding in both cases and it would be helpful to know if the
problem is general or is specific to this one dialog.
(Reporter)

Comment 4

19 years ago
Here is the breakdown by platform:

1. Linux build 1999071908 shows none of these problems.
2. On the mac build, both the safe form fill and display cookies dialogs are
blank (they both look identical when they pop up)
3. On win32, the safe form fill dialog is ok, but the display cookies dialog
freezes up apprunner.

Updated

19 years ago
Resolution: DUPLICATE → ---

Comment 5

19 years ago
Clearing Duplicate resolution due to ReOpen of this bug.

Comment 6

19 years ago
Are you sure about the display-cookie dialog freezing up apprunner on win32?  I
just pulled a fresh tree and tried it and did not get that behaviour at all.
Can you try it with the latest tree.
(Reporter)

Updated

19 years ago
OS: All → Mac System 8.5
Hardware: All → Macintosh
(Reporter)

Comment 7

19 years ago
With win32 build 1999071911 (today's respin)...both the Edit | Wallet | Safe
Form Fill and Edit | Waller | Display Cookies dialogs are BOTH OK.  Changing
platform and os to Mac 8.5 since both dialogs are still blank on mac.

Updated

19 years ago
Status: REOPENED → ASSIGNED

Comment 8

19 years ago
Now it only took me half a day to get a mac build and test this out.  What I am
seeing is that not a blank pop-up but rather no pop-up at all for display
cookies and safe fill-in.  In fact, any menu item I select gives me the
following diagnostic message:

  "Throwing away key event because there is no focused widget
   at nsMacEventHandler.cpp"

paulmac and jpatel: are either of you seeing this behavior?

Comment 9

19 years ago
Steve, this is a known focus issue bug. You just need to click in the browser
window once, then the menu items will work for you. At least this was the status
last Thursday...

I will check out with today's build and let you know if I see something
different.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 10

19 years ago
Thanks Paul, clicking in the browser window sure made the difference.  That's a
nasty bug and I assume that there already is a report on it so I won't file one.

Now that I got passed that problem, I was able to test out the blank screens
reported here.  And guess what?  I didn't get a blank screen at all but rather
got exactly the window I expected.  In the case of display-cookies I indeed saw
the cookie viewer.  And in the case of safe fill-in I indeed saw the list of
things that could be filled in for me.

So what am I doing differently than jpatel?  The only thing I can think of is
that something else got changed which fixed this bug.  I am therefore closing
this report out as "works for me".

Comment 11

19 years ago
Odds are it was fixed, because I saw the same thing Jay saw. We'll wait for
today's builds to verify.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 12

19 years ago
I am still see-ing this, on a clean build from noon today. Created a new
profile, ran it, and immediately went to Display Cookies, where it was blank.
Other viewers blank also. Re-opening.

Comment 13

19 years ago
Paul, what are we doing differently?  All four viewers definitely work for me on
the mac.  Also, didn't you report that they worked for you in the recent past,
like in the last week or two.  As of what build did they stop working?

Updated

19 years ago
Summary: Edit | Wallet | Safe Form Fill window is blank → [PP] Edit | Wallet | Safe Form Fill window is blank
(Reporter)

Comment 14

19 years ago
Just to confirm paul's findings, i too am still getting blank windows for safe
form fill and display cookies dialogs on mac build 1999072010.  The top bar does
not have close, minimize, etc. buttons and most of the window is gray, except
for a small square on the bottom right corner...if that helps any.

Comment 15

19 years ago
Jay, can you check your daily smoketest results and see when this stopped
working? Thanks.

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 16

19 years ago
Clearing WorksForMe resolution due to Reopen.

Comment 17

19 years ago
Sorry, I thought I had updated this already. The bug was introduced sometime
over the weekend, because it was working Friday and is not working today, per
http://slip/projects/seamonkey/smoketests/

Updated

19 years ago
Assignee: morse → hyatt
Status: REOPENED → NEW

Comment 18

19 years ago
This is the wallet being broken again. Steve didn't checkin anything to make
this happen. Dialogs changes are good starting point. Reassinging to hyatt.

Comment 19

19 years ago
this is definitely a blocker
(Reporter)

Comment 20

19 years ago
This also applies to "Wallet Contents" and "Display Cookies" dialogs

Updated

19 years ago
Priority: P3 → P1
Whiteboard: BLOCKER CONFIRMED
Target Milestone: M9

Updated

19 years ago
Assignee: hyatt → danm

Comment 21

19 years ago
Reassigning to danm.

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: BLOCKER CONFIRMED → working on Windows and Mac. gtk still broken.

Updated

19 years ago
Whiteboard: working on Windows and Mac. gtk still broken. → working on Windows and Mac. gtk problem undiagnosed.

Updated

19 years ago
Summary: [PP] Edit | Wallet | Safe Form Fill window is blank → [PP] Edit | Wallet | Display Cookies window is blank

Comment 22

19 years ago
This is actually a platform specific bug dealing with the various wallet viewers
coming up blank, so the status whiteboard doesn't make sense to me. The Safe
Form Fill Window just started coming up correctly, but the Display Cookies and
Display Signons are still blank.

Updated

19 years ago
Target Milestone: M9 → M10

Comment 23

19 years ago
Out of time for M9.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 24

19 years ago
Is this still a problem?  It's hard to tell.  Here's my testing results with today's build:
Display Cookies/Signons: all platforms, no problems.  The windows are uglier than a drunken armadillo,
but they're not empty.  Stepping through the original bug report, I get different results on all platforms,
but no blank windows:
Windows: everything seems to work (including filling out a simple form on Amazon)
Linux: segmentation fault loading http://people.netscape.com/morse/wallet/samples/INTERVIEW.HTML
Mac: claims (using a non-empty alert window) there is nothing to fill out on the Amazon formp

These would all be different bugs.  But with the possible exception of crashing Linux, I'm not seeing
any blank windows.  Poking the "worksforme" button again.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 25

19 years ago
verified worksforme...I haven't seen any blank windows for a while and some of
the other problems with autofill already have bugs logged on them.

Comment 26

19 years ago
the display signons page is now the only one having problems. I will just open a
new one on that, this bug report has gotten messy.

Updated

19 years ago
Blocks: 7530

Updated

10 years ago
Assignee: danm.moz → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: paulmac → form.manager
Target Milestone: M10 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.