Closed Bug 977520 Opened 7 years ago Closed 7 years ago

Rendering issue with 1/1 Direct3D 11 (OMTC) enabled

Categories

(Core :: Graphics: Layers, defect)

28 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox28 - wontfix
firefox29 - affected
firefox30 - affected

People

(Reporter: bogdan_maris, Unassigned)

References

Details

(Keywords: regression)

Reproducible on Firefox 28 beta 6 (BuildID: 20140224220227):
Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0
Reproducible on the latest Aurora (BuildID: 20140226004001):
Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0
Reproducible on the latest Nightly (BuildID: 20140226030202): 
Mozilla/5.0 (Windows NT 6.1; rv:30.0) Gecko/20100101 Firefox/30.0

Steps to reproduce:
1. Launch Firefox
2. Go to about:config
3. Set 'layers.offmainthreadcomposition.enabled' to true
4. Restart the browser
5. Go to http://savethedatestory.com/daraandchris/
6. Scroll on the page

Expected results:
The scrolling goes smooth with no rendering issues.

Actual results:
There are some rendering issue when scrolling.

Notes:
1. This issue is a regression

m-c:
Last good revision: a475f94bb1b1 (2013-11-17)
First bad revision: beddd6d4bcdf (2013-11-18)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a475f94bb1b1&tochange=beddd6d4bcdf

m-i:
Last good revision: a475f94bb1b1
First bad revision: f2c02e984744
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a475f94bb1b1&tochange=f2c02e984744

2. This is reproducible on Windows Vista, Windows 7 and Windows 8.1.
3. Screencast showing the issue: 
http://www.screencast.com/t/VqP9UsR7
Nominating for tracking, though unless we plan to ship OMTC enabled by default in Firefox 28 this shouldn't block.
Flags: needinfo?(release-mgmt)
Version: Trunk → 28 Branch
I don't think we would need to track this considering its not a default behavior and will only impact a small group of users at best. There are are other options in about:config that if toggled on could impact a segment of our users.
Flags: needinfo?(release-mgmt)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)
> Actual results:
> There are some rendering issue when scrolling.

Even if you put in the screencast, it's helpful to have a one-line description of what kind of rendering issues you are seeing, so someone can make a fast assessment without watching the whole screencast.

In this case, it looks like it's the transparent areas of the images being rendered in black instead, but either it's not always happening or it's correcting itself, I can't figure that out from watching.
Based on the current status of this bug and where we're at in the schedule I'm calling this wontfix for Firefox 28.
Is this fixed on nightly?
Lack of response leads me to believe this no longer occurs.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.