Closed Bug 977523 Opened 7 years ago Closed 7 years ago

Comment textarea has padding:0

Categories

(Bugzilla :: User Interface, defect)

4.5.2
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Bugzilla 5.0

People

(Reporter: mats, Assigned: glob)

Details

Attachments

(5 files)

This very textarea I'm typing into right now, has padding:0 in the
stylesheet "global.css" line 622.  This looks *horrible*.
Please remove that so that it has the default padding.
Horrible how? Screenshot?
Also missing any Bugzilla version information or browser info...
Flags: needinfo?(matspal)
Version is not hard to guess: the code has just been committed to trunk and backported to bmo.
Severity: normal → minor
OS: Linux → All
Hardware: x86_64 → All
Version: unspecified → 4.5.2
When there's no text the caret is hardly visible...
Flags: needinfo?(matspal)
Note how the "W" touches the left edge...
Look, there's a *reason* the Firefox UA sheet specifies a non-zero default padding
for textareas.  Please don't mess with that.
I guess you use Firefox, so what you do get when you remove padding:0 using the dev tools? I see absolutely no difference compared to Bugzilla 4.4, and 4.4 doesn't have padding:0. And if I use the dev tools to remove padding:0, this doesn't change anything either.
I'm using Nightly 30.0a1 (2014-02-25) on Linux64.  When I remove the padding:0 using devtools
then it looks good again.
(In reply to Mats Palmgren (:mats) from comment #8)
> I'm using Nightly 30.0a1 (2014-02-25) on Linux64.  When I remove the
> padding:0 using devtools
> then it looks good again.

Screenshot, please. Arguing that it looks good vs looks horrible is pretty useless.
Can you reproduce it?  http://nightly.mozilla.org/
There's another rule at global.css:76 that also specifies padding, please remove that too.
After disabling *both* in devtools then it looks like I get the default padding.
Attached image Screenshot
Here is what I get with Firefox 27.0.1 on Linux:
above with padding: 0 enabled, below with padding: 0 disabled. No difference. In both cases, it looks good.
Ah, I see why you have such a padding. That's because you use the Mozilla skin while I use the Dusk skin. The Mozilla skin uses its own padding.
I see the same problem in the Dusk skin, which also has the padding:0 rule
(but not the other one).  The reason you're not seeing a difference in FF27
when disabling it might be bug 157846 which is fixed in Nightly.  The default
horizontal padding should be 1px (reported in devtools Computed style view
when you click "Browser styles").  In Nightly I do see the 1px difference,
and it definitely looks nicer ;-)

Please just remove all specified padding for form controls in general.
It's not a good idea to mess around with it.
Assignee: ui → glob
Status: NEW → ASSIGNED
Attached patch 977523_1.patchSplinter Review
sorry, i don't know what i was thinking :)
Attachment #8383513 - Flags: review?(gerv)
Please also remove the padding at "global.css:76" for the Mozilla theme.  Thanks.
Target Milestone: --- → Bugzilla 5.0
(In reply to Mats Palmgren (:mats) from comment #17)
> Please also remove the padding at "global.css:76" for the Mozilla theme. 

i'll do that when i backport this bug to bmo :)
Comment on attachment 8383513 [details] [diff] [review]
977523_1.patch

> #comment_preview {
>     border: 1px solid silver;
>-    padding: 0px 1px;
>+    padding: 1px;

I don't understand exactly the goal of padding here. Is it because the padding is too large by default and you want it smaller? You could as well drop this rule, IMO. But I'm fine in both cases, so r=LpSolit
Attachment #8383513 - Flags: review?(gerv) → review+
Flags: approval?
Flags: approval? → approval+
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bugzilla/trunk/
modified skins/standard/global.css
Committed revision 8950.

(In reply to Mats Palmgren (:mats) from comment #17)
> Please also remove the padding at "global.css:76" for the Mozilla theme. 
i experimented with this suggestion, and have left the padding in place as the extra padding suits the mozilla theme well.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.