Closed Bug 977623 Opened 7 years ago Closed 7 years ago

bookmark and history panel opens too far to the left

Categories

(Firefox :: Bookmarks & History, defect)

29 Branch
x86_64
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 974389

People

(Reporter: marcausl, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P5] p=5)

If the bookmark icon and/or history icon is placed to the left of the address bar in the location bar, the bookmark panel and history panel now open to the left, overlapping the left side of the firefox window.  This only happens if there is room to the left of the window for the panel.  If there is no room, the panel opens to the right, as it did until the 02/27/2014 update of aurora.

IMHO, the panel should always open inside the firefox window.
Maria - I don't know why you sent me an email.  The appropriate place to discuss a bug is the bug report.  This includes asking for more information.

I thought the report was clear.  Customize the bookmark or history icon to the left end of the location bar.  Make sure there is plenty of room on the desktop to the left of the firefox window.  Click on the icon and the panel opens partially outside the firefox window.

Also, only the latest aurora shows this.
This fails on Windows but not on Linux - at least not my Linux.
Whiteboard: [Australis:P5]
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Reproduced on latest Nightly (20140323030203), marking as New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Let me stress that to reproduce this, you need enough room to the left of the Firefox window on the screen.  If you don't see it move the left edge of the Firefox screen right to increase the distance.
Flags: firefox-backlog+
I think it should do this, so I disagree on that point with you, no menu/panel on windows/osx/linux obeys their opener's window margins. As well they shouldn't, on smaller windows these would barely be shown at all. I think it's by definition that menus/panels are "above" their opener window.
Whiteboard: [Australis:P5] → [Australis:P5] p=5
Could this be a dupe of Bug 974389?
(In reply to simone.lando from comment #6)
> Could this be a dupe of Bug 974389?

Yes.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: firefox-backlog+
Resolution: --- → DUPLICATE
Duplicate of bug: 974389
You need to log in before you can comment on or make changes to this bug.