Closed Bug 977679 Opened 6 years ago Closed 6 years ago

test_webgl_conformance_test_suite.html | Assertion count 2 is greater than expected range 0-0 assertions. on Android 4.0 Debug

Categories

(Firefox for Android :: General, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 974699

People

(Reporter: gbrown, Assigned: jgilbert)

References

Details

We are trying to get the Android 4.0 Debug tests to run green on Cedar, so that they can be run on trunk trees, including try.

Recent fixes for Android 4.0 Debug mochitest-gl have reduced the error count there to just one failure -- this one.

https://tbpl.mozilla.org/php/getParsedLog.php?id=35283723&tree=Cedar&full=1

08:12:43     INFO -  526 INFO TEST-INFO | MEMORY STAT heapAllocated after test: 40871556
08:12:43     INFO -  527 INFO TEST-END | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | finished in 536633ms
08:12:43     INFO -  528 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Assertion count 2 is greater than expected range 0-0 assertions.
08:12:43     INFO -  529 INFO TEST-START | Shutdown
08:12:43     INFO -  530 INFO Passed:  7304
08:12:43  WARNING -  531 INFO Failed:  1

Complete logcat for this run at http://mozilla-releng-blobs.s3.amazonaws.com/blobs/cedar/sha512/9eb2f5d565e3cdbf460c30c82b6681bdc541cf1857eac865d1fc9dbdd45dff587472ec9596d2c817a6ddfe44019b920232621e8a16b5f2720355ffbc0d5dcb5f contains:

02-26 08:09:36.445 E/GeckoConsole( 2227): conformance/textures/tex-image-and-sub-image-2d-with-image-data.html: finished
02-26 08:09:36.445 E/GeckoConsole( 2227): loading: conformance/textures/tex-image-and-sub-image-2d-with-image.html
02-26 08:09:36.453 E/GeckoConsole( 2227): FAIL
02-26 08:09:36.453 E/GeckoConsole( 2227): conformance/textures/tex-image-and-sub-image-2d-with-image.html: finished
02-26 08:09:36.453 E/GeckoConsole( 2227): loading: conformance/textures/tex-image-and-sub-image-2d-with-video.html
02-26 08:09:36.523 I/Gecko   ( 2227): ++DOMWINDOW == 13 (0x6672a520) [pid = 2227] [serial = 264] [outer = 0x6b202560]
02-26 08:09:36.671 E/GeckoConsole( 2227): [JavaScript Warning: "All candidate resources failed to load. Media load paused." {file: "http://mochi.test:8888/tests/content/canvas/test/webgl/conformance/textures/tex-image-and-sub-image-2d-with-video.html" line: 0}]
02-26 08:09:36.867 I/Gecko   ( 2227): [2227] WARNING: NS_ENSURE_TRUE(WrapperFactory::IsXrayWrapper(wrapper)) failed: file /builds/slave/ced-and-d-00000000000000000000/build/js/xpconnect/wrappers/XrayWrapper.cpp, line 554
02-26 08:09:36.953 I/Gecko   ( 2227): void mozilla::AndroidBridge::HandleGeckoMessage(const nsAString_internal&)
02-26 08:09:36.960 I/Gecko   ( 2227): [2227] WARNING: NS_ENSURE_TRUE(WrapperFactory::IsXrayWrapper(wrapper)) failed: file /builds/slave/ced-and-d-00000000000000000000/build/js/xpconnect/wrappers/XrayWrapper.cpp, line 554
02-26 08:09:36.968 I/Gecko   ( 2227): [2227] WARNING: NS_ENSURE_TRUE(WrapperFactory::IsXrayWrapper(wrapper)) failed: file /builds/slave/ced-and-d-00000000000000000000/build/js/xpconnect/wrappers/XrayWrapper.cpp, line 554
02-26 08:09:36.968 I/Gecko   ( 2227): [2227] WARNING: NS_ENSURE_TRUE(WrapperFactory::IsXrayWrapper(wrapper)) failed: file /builds/slave/ced-and-d-00000000000000000000/build/js/xpconnect/wrappers/XrayWrapper.cpp, line 554
02-26 08:09:36.976 I/MediaPluginHost( 2227): Android Version is: 15
02-26 08:09:36.976 I/MediaPluginHost( 2227): Android Release Version is: 4.0.4
02-26 08:09:36.976 I/MediaPluginHost( 2227): Android Device is: pandaboard
02-26 08:09:36.976 I/MediaPluginHost( 2227): Android Manufacturer is: unknown
02-26 08:09:36.976 I/MediaPluginHost( 2227): Android Hardware is: omap4pandaboard
02-26 08:09:36.976 I/Gecko   ( 2227): [2227] WARNING: XXX stagefright blacklisted
02-26 08:09:36.976 I/Gecko   ( 2227): : file /builds/slave/ced-and-d-00000000000000000000/build/content/media/plugins/MediaPluginHost.cpp, line 120
02-26 08:09:36.976 I/MediaPluginHost( 2227): Loading OMX Plugin: nullptr
02-26 08:09:36.976 I/Gecko   ( 2227): [2227] ###!!! ASSERTION: Network state should be loading: 'mNetworkState == nsIDOMHTMLMediaElement::NETWORK_LOADING', file /builds/slave/ced-and-d-00000000000000000000/build/content/html/content/src/HTMLMediaElement.cpp, line 936
02-26 08:09:36.976 I/Gecko   ( 2227): [2227] WARNING: NS_ENSURE_TRUE(WrapperFactory::IsXrayWrapper(wrapper)) failed: file /builds/slave/ced-and-d-00000000000000000000/build/js/xpconnect/wrappers/XrayWrapper.cpp, line 554
02-26 08:09:36.984 I/MediaPluginHost( 2227): Android Version is: 15
02-26 08:09:36.984 I/MediaPluginHost( 2227): Android Release Version is: 4.0.4
02-26 08:09:36.984 I/MediaPluginHost( 2227): Android Device is: pandaboard
02-26 08:09:36.984 I/MediaPluginHost( 2227): Android Manufacturer is: unknown
02-26 08:09:36.984 I/MediaPluginHost( 2227): Android Hardware is: omap4pandaboard
02-26 08:09:36.984 I/Gecko   ( 2227): [2227] WARNING: XXX stagefright blacklisted
02-26 08:09:36.984 I/Gecko   ( 2227): : file /builds/slave/ced-and-d-00000000000000000000/build/content/media/plugins/MediaPluginHost.cpp, line 120
02-26 08:09:36.984 I/MediaPluginHost( 2227): Loading OMX Plugin: nullptr
02-26 08:09:36.984 I/Gecko   ( 2227): [2227] ###!!! ASSERTION: Network state should be loading: 'mNetworkState == nsIDOMHTMLMediaElement::NETWORK_LOADING', file /builds/slave/ced-and-d-00000000000000000000/build/content/html/content/src/HTMLMediaElement.cpp, line 936
Assignee: nobody → jgilbert
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 974699
Resolution: --- → DUPLICATE
Duplicate of bug: 974699
You need to log in before you can comment on or make changes to this bug.