Using custom tab widths breaks bug #465086

VERIFIED WORKSFORME

Status

()

defect
--
major
VERIFIED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Virtual, Unassigned)

Tracking

({nightly-community, reproducible})

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Using this code 

.tabbrowser-tab:not([pinned])[fadein]{ min-width: 54px !important; }

or

.tabbrowser-tab:not([pinned]) {
  max-width: 250px !important;
  min-width: 54px !important;
}
.tabbrowser-tab:not([pinned]):not([fadein]) {
  max-width: 0.1px !important;
  min-width: 0.1px !important;
}

in custom userChrome.css breaks bug #465086 as tabs resize when I closing a tab with the mouse instead of maintaining the same size until the mouse exits the tab bar area.
What's more the same thing happens when you add this code in add-on.

Comment 1

5 years ago
This looks like a dup of bug 649624
It's not a duplicate as I'm talking also about custom userChrome.css, not only an add-on, so using both features breaks another.
Any ideas guys?
Flags: needinfo?(fryn)
Flags: needinfo?(dao)

Updated

5 years ago
Flags: needinfo?(fryn)
The Custom Tab Width add-on (<https://addons.mozilla.org/en-US/firefox/addon/custom-tab-width/>) doesn't seem to have this problem, so I'm guessing your code is wrong.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(dao)
Resolution: --- → WORKSFORME
Yes, looks like it was the case, as I can't reproduce it anymore also with Classic Theme Restorer. Thank you very much for looking and reply.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.