Closed Bug 978068 Opened 6 years ago Closed 6 years ago

attribute [fastcustomizeanimation] set on #content-deck, but CSS targets #tab-view-deck

Categories

(Firefox :: Toolbars and Customization, defect)

29 Branch
x86_64
Windows Vista
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: mcdavis941.bugs, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3-][qa-])

Attachments

(1 file)

This is based on a very quick look at the code, but it looks like attribute [fastcustomizeanimation] is set on #content-deck, in CustomizeMode.jsm, but CSS in content/browser.css is trying to match that attribute on #tab-view-deck.  I'm looking at Aurora.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Whiteboard: [Australis:P3-]
This is a regression from bug 962677.
Blocks: 962677
Fortunately the fix isn't particularly interesting...
Attachment #8383693 - Flags: review?(mdeboer)
Comment on attachment 8383693 [details] [diff] [review]
fastcustomizeanimation attribute set on wrong tab,

LGTM. Thanks for the quick turn-around.
Attachment #8383693 - Flags: review?(mdeboer) → review+
(In reply to mcdavis941 (sporadically reading bugmail) from comment #0)
> This is based on a very quick look at the code, but it looks like attribute
> [fastcustomizeanimation] is set on #content-deck, in CustomizeMode.jsm, but
> CSS in content/browser.css is trying to match that attribute on
> #tab-view-deck.  I'm looking at Aurora.

Whoops. Thanks for catching that, mcdavis941!
remote:   https://hg.mozilla.org/integration/fx-team/rev/963cc574a100
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/963cc574a100
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 30
Comment on attachment 8383693 [details] [diff] [review]
fastcustomizeanimation attribute set on wrong tab,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis / bug 962677
User impact if declined: fast transition pref is broken, automated tests take longer as a consequence
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low-none
String or IDL/UUID changes made by this patch: none
Attachment #8383693 - Flags: approval-mozilla-aurora?
Attachment #8383693 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [Australis:P3-] → [Australis:P3-][qa-]
You need to log in before you can comment on or make changes to this bug.