Closed Bug 978168 Opened 6 years ago Closed 6 years ago

Intermittent test_pixel_lengths.html | application crashed [@ nsPresContext::AppUnitsPerDevPixel()]

Categories

(Core :: Layout, defect, critical)

x86
Windows Phone 8
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 891840

People

(Reporter: emorley, Unassigned)

Details

(Keywords: crash)

Crash Data

WINNT 6.2 fx-team pgo test mochitest-5 on 2014-02-28 02:18:20 PST for push 26020d6a32f2

slave: t-w864-ix-036

https://tbpl.mozilla.org/php/getParsedLog.php?id=35412040&tree=Fx-Team

{
02:24:03     INFO -  1511 INFO TEST-START | /tests/layout/style/test/test_pixel_lengths.html
02:24:03     INFO -  1512 INFO TEST-INFO | MEMORY STAT vsize after test: 633491456
02:24:03     INFO -  1513 INFO TEST-INFO | MEMORY STAT vsizeMaxContiguous after test: 1893662720
02:24:03     INFO -  1514 INFO TEST-INFO | MEMORY STAT residentFast after test: 237117440
02:24:03     INFO -  1515 INFO TEST-INFO | MEMORY STAT heapAllocated after test: 73488932
02:24:05     INFO -  NPP_Destroy
02:24:05     INFO -  NPP_Destroy
02:24:05     INFO -  NPP_Destroy
02:24:05     INFO -  NPP_Destroy
02:24:05     INFO -  NPP_Destroy
02:24:05     INFO -  NPP_Destroy
02:24:05  WARNING -  TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_pixel_lengths.html | application terminated with exit code 3221225477
02:24:05     INFO -  INFO | runtests.py | Application ran for: 0:02:24.689000
02:24:05     INFO -  INFO | zombiecheck | Reading PID log: c:\users\cltbld~1.t-w\appdata\local\temp\tmpfd0rfapidlog
02:24:05     INFO -  ==> process 3596 launched child process 2812 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=3596.b476ae0.877695605 "c:\users\cltbld~1.t-w\appdata\local\temp\tmpzlt78d\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 3596 "\\.\pipe\gecko-crash-server-pipe.3596" plugin)
02:24:05     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-win32-pgo/1393574403/firefox-30.0a1.en-US.win32.crashreporter-symbols.zip
02:24:12  WARNING -  PROCESS-CRASH | /tests/layout/style/test/test_pixel_lengths.html | application crashed [@ nsPresContext::AppUnitsPerDevPixel()]
02:24:12     INFO -  Crash dump filename: c:\users\cltbld~1.t-w\appdata\local\temp\tmpzlt78d\minidumps\2d04972f-4268-41dd-a573-10c8e52e12d5.dmp
02:24:12     INFO -  Operating system: Windows NT
02:24:12     INFO -                    6.2.9200
02:24:12     INFO -  CPU: x86
02:24:12     INFO -       GenuineIntel family 6 model 30 stepping 5
02:24:12     INFO -       8 CPUs
02:24:12     INFO -  Crash reason:  EXCEPTION_ACCESS_VIOLATION_READ
02:24:12     INFO -  Crash address: 0x10
02:24:12     INFO -  Thread 0 (crashed)
02:24:12     INFO -   0  xul.dll!nsPresContext::AppUnitsPerDevPixel() [nsPresContext.cpp:26020d6a32f2 : 2767 + 0x3]
02:24:12     INFO -      eip = 0x72904066   esp = 0x006abcf8   ebp = 0x006abd34   ebx = 0x0000000b
02:24:12     INFO -      esi = 0x08e951a0   edi = 0x18bef800   eax = 0x00000000   ecx = 0x18bef800
02:24:12     INFO -      edx = 0x642e6970   efl = 0x00010202
02:24:12     INFO -      Found by: given as instruction pointer in context
02:24:12     INFO -   1  xul.dll!nsPresContext::PreferenceChanged(char const *) [nsPresContext.cpp:26020d6a32f2 : 899 + 0x6]
02:24:12     INFO -      eip = 0x7346871d   esp = 0x006abcfc   ebp = 0x006abd34
02:24:12     INFO -      Found by: call frame info
02:24:12     INFO -   2  xul.dll!nsPresContext::PrefChangedCallback(char const *,void *) [nsPresContext.cpp:26020d6a32f2 : 217 + 0xa]
02:24:12     INFO -      eip = 0x73468813   esp = 0x006abd3c   ebp = 0x006abd4c
02:24:12     INFO -      Found by: call frame info
02:24:12     INFO -   3  xul.dll!mozilla::ValueObserver::Observe(nsISupports *,char const *,wchar_t const *) [Preferences.cpp:26020d6a32f2 : 164 + 0x8]
02:24:12     INFO -      eip = 0x72861eb5   esp = 0x006abd54   ebp = 0x006abdc0
02:24:12     INFO -      Found by: call frame info
02:24:12     INFO -   4  xul.dll!nsPrefBranch::NotifyObserver(char const *,void *) [nsPrefBranch.cpp:26020d6a32f2 : 697 + 0x41]
02:24:12     INFO -      eip = 0x7266d5f3   esp = 0x006abdc8   ebp = 0x006abed8
02:24:12     INFO -      Found by: call frame info
02:24:12     INFO -   5  xul.dll!pref_DoCallback [prefapi.cpp:26020d6a32f2 : 952 + 0xc]
02:24:12     INFO -      eip = 0x728243f4   esp = 0x006abee0   ebp = 0x006abef8
02:24:12     INFO -      Found by: call frame info
02:24:12     INFO -   6  xul.dll!pref_HashPref [prefapi.cpp:26020d6a32f2 : 798 + 0xc]
02:24:12     INFO -      eip = 0x72822e80   esp = 0x006abf00   ebp = 0x006abf14
02:24:12     INFO -      Found by: call frame info
02:24:12     INFO -   7  xul.dll!nsPrefBranch::SetIntPref(char const *,int) [nsPrefBranch.cpp:26020d6a32f2 : 210 + 0x13]
02:24:12     INFO -      eip = 0x726851f8   esp = 0x006abf1c   ebp = 0x006abf30
02:24:12     INFO -      Found by: call frame info
02:24:12     INFO -   8  xul.dll!mozilla::Preferences::SetIntPref(char const *,int) [Preferences.h:26020d6a32f2 : 49 + 0x13]
02:24:12     INFO -      eip = 0x72884989   esp = 0x006abf38   ebp = 0x006abf44
02:24:12     INFO -      Found by: call frame info
}
Looks like this started very recently, is it a regression?
No. It's a dupe of bug 891840 which has been going on for a long time now without much attention. The only change is a more recent morph of the stack to this.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 891840
You need to log in before you can comment on or make changes to this bug.