simple <button> in a form causes submit

VERIFIED INVALID

Status

()

Core
HTML: Form Submission
--
major
VERIFIED INVALID
17 years ago
7 years ago

People

(Reporter: Doron Rosenberg (IBM), Assigned: rods (gone))

Tracking

(Blocks: 1 bug, {regression})

Trunk
mozilla0.9.5
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: critical for 0.9.4)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
As the testcase that I will attach shows, it seems that any <button> in a form
will cause it to submit.  This seems to be a regression.
(Reporter)

Comment 1

17 years ago
Created attachment 47843 [details]
simple testcase
(Reporter)

Comment 2

17 years ago
forgot to say, seeing this in the 27th build, bclary was seeing it with a later
build too I believe
Severity: normal → major
Keywords: regression

Comment 3

17 years ago
the last known build that does not have this behavior is trunk 2001081703/win2k

Updated

17 years ago
Whiteboard: critical for 0.9.4

Updated

17 years ago
OS: other → All
Target Milestone: --- → mozilla0.9.4

Updated

17 years ago
Blocks: 39985

Comment 4

17 years ago
Sounds pretty ugly. Added "nsbranch" keyword.
Keywords: nsbranch
Set milestone to mozilla0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 6

17 years ago
I would like to nominate this bug for nsenterprise.
Buttons could be used for other purposes than
submission. If non-submit type buttons always cause
"submit" action, many forms will become unusable.
Keywords: nsenterprise

Comment 7

17 years ago
This problem occurs in build 2001082309/win2k. 

So the problem occured somewhere between 8/17 and 8/23. Sorry, but I don't have
any builds from any intermediate dates and it takes me over and hour to dl a
complete build. Perhaps someone else can help localize the problem more.

Comment 8

17 years ago
The problem began with the 8/21/2001 trunk build. 
On my 8/20 build, it is not a problem but with the 
8/21 build, this problem occurs.
(Assignee)

Comment 9

17 years ago
This is a dup and I have submitted a patch, I have to find what the bug # is.
(Assignee)

Comment 10

17 years ago

*** This bug has been marked as a duplicate of 59035 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 11

17 years ago
I don't think that this is a bug. According to:

    http://www.w3.org/TR/html4/interact/forms.html#edef-BUTTON

the default type for button is submit.

Comment 12

17 years ago
kin, you are absolutely right. here i am evangelizing standards and never used
type on buttons... always assuming the default type was button. This is
something for all of us evangers to remember. The correct default for button
type is submit but that does differ from IE and from earlier behavior in
Mozilla. We will need to remember this when evanging sites, but the change in
default behavior may cause us a little trouble. Fortunately it appears that
hardly anyone depends on the default type being button as i did.

Comment 13

17 years ago
verifying duplicate
Status: RESOLVED → VERIFIED

Comment 14

17 years ago
How can this be a dup of bug 59035?  Bug 59035 is the opposite of this bug.

Comment 15

17 years ago
Jesse's right. Reopening and closing as INVALID.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 16

17 years ago
--> INVALID
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID

Comment 17

17 years ago
verifying invalid
Status: RESOLVED → VERIFIED

Comment 18

17 years ago
*** Bug 105399 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 155294 has been marked as a duplicate of this bug. ***
*** Bug 188544 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
*** Bug 192163 has been marked as a duplicate of this bug. ***

Comment 22

13 years ago
*** Bug 288289 has been marked as a duplicate of this bug. ***

Comment 23

13 years ago
*** Bug 304002 has been marked as a duplicate of this bug. ***

Comment 24

13 years ago
*** Bug 313484 has been marked as a duplicate of this bug. ***

Comment 25

12 years ago
*** Bug 317910 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Duplicate of this bug: 400651
Duplicate of this bug: 407662
Duplicate of this bug: 389431
Duplicate of this bug: 274061
Duplicate of this bug: 272958

Updated

10 years ago
Duplicate of this bug: 429068

Updated

10 years ago
Duplicate of this bug: 454722

Updated

10 years ago
Duplicate of this bug: 457818
You need to log in before you can comment on or make changes to this bug.