HTML Editor/Composer: Implement text highlight feature to apply background color to selected text (inline css <span style="background-color:xxx">)

RESOLVED DUPLICATE of bug 318600

Status

RESOLVED DUPLICATE of bug 318600
18 years ago
3 years ago

People

(Reporter: TucsonTester1, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 20010830 Netscape6/6.1b1

1.  Open a blank composer document to edit.
2.  Type some random text.
3.  Using your mouse, highlight some of the text.
4.  In the Text Formatting bar, click the text color pallette and choose a text
color other than black or white.
5.  Leaving the text highlighted, click on the text background color pallette.

Result:
A pallette opens for Page Background color.  This functionality is located near
the bottom of the Format menu already, and I expected to find it there.  I
didn't expect to find it where a text background color pallette should be. 

I have seen this occur on OS 8.6, OS 9.1, and OS X only.  I have not tested
other platforms. 

Date:
8/31/01

Notes:
The only way I could figure out how to change the text background color is by
manually entering a span style="background-color: tag.

Comment 1

18 years ago
Reporter, please retest using a Mozilla (not Netscape) build.

Comment 2

18 years ago
Greg: This is a QA Build - should still be valid.

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer

Comment 4

17 years ago
We need to fix the color chips on the formatting toolbar.
Status: NEW → ASSIGNED
OS: Mac System 8.6 → All
Hardware: Macintosh → All
Whiteboard: EDITORBASE 1 day
Target Milestone: --- → mozilla0.9.6

Updated

17 years ago
Depends on: 77705

Updated

17 years ago
Summary: Page background color pallette is placed in an illogical position → Page background color palette is placed in an illogical position
Target Milestone: mozilla0.9.6 → mozilla0.9.8

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Comment 5

17 years ago
See also bug 121210, can't select paragraph background color easily.

Comment 6

17 years ago
The overlapping squares on the toolbar represent the standard 
'Forground / Background' type of widget used in graphic programs. If you click
on the square that is "behind", that brings up colorpicker for cell/table/page
background. As brade mentions, this UI will probably change to a new pattern
given the new "text background" icon added when in CSS attribute mode (set in 
composer prefs (see bug 121210).
Assignee: brade → cmanske
Status: ASSIGNED → NEW

Comment 7

17 years ago
we should discuss this at our next meeting (esp. if Daniel is around)

Comment 8

17 years ago
I agree CSS composing brings this issue to the front, but I don't see it as
EDITORBASE by our definition (function works as intended, and I'd like to see
some usability people involved before we make any decisions).
Whiteboard: EDITORBASE 1 day → EDITORBASE- 1 day

Comment 9

17 years ago
*** Bug 121210 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
only nsbeta1+ bugs can have milestones, resetting to ---
Target Milestone: mozilla0.9.9 → ---

Comment 11

17 years ago
We need 3 icons! Should be done for 1.0
Status: NEW → ASSIGNED
Keywords: nsbeta1
Target Milestone: --- → mozilla1.0
I have a proposal on my plate. Just need some find some other minutes to
dive into my favorite drawing tool.

Comment 13

17 years ago
-->glazman for his work (0.9.9?)  
When he has attached images he can reassign to cmanske or check in the work himself.
Assignee: cmanske → glazman
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0 → mozilla0.9.9
Marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Setting Milestone to Moz1.1
Target Milestone: mozilla0.9.9 → mozilla1.1

Comment 16

17 years ago
Glazman's text highlighting is now working when you are in "CSS Mode" 
(set in Composer preferences), so this is now fixed.
Use the "highlight" toolbar button to bring up colorpicker for text background
We know we have issues with the toolbar widget design, but those are covered in
other bugs.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 17

17 years ago
reopen bug since I don't think this has been addressed yet (toolbar
positioning/order/placement of color chips)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 18

17 years ago
Removing '-' for Buffy consideration and taking bug.
Assignee: glazman → cmanske
Status: REOPENED → NEW
Keywords: nsbeta1- → nsbeta1
Whiteboard: EDITORBASE- 1 day
Target Milestone: mozilla1.1alpha → mozilla1.2alpha

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1 → nsbeta1+
Summary: Page background color palette is placed in an illogical position → Redesign the toolbar color chip (picker triggers)

Comment 19

16 years ago
Composer triage team: nsbeta1-
Keywords: nsbeta1+ → nsbeta1-
Product: Browser → Seamonkey
Assignee: cmanske → nobody
Status: ASSIGNED → NEW
QA Contact: sujay → composer
Target Milestone: mozilla1.2alpha → ---

Comment 20

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 21

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 22

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 23

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 24

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 25

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 26

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 27

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago9 years ago
Resolution: --- → EXPIRED
This problem isn't resolved while we've got too many bugs for the same issue in TB and SeaMonkey. This seems to be one of the oldest occurences and comes with reasonable STR which also point to the wrong design of the toolbar color picker.

-> reopening with intention of consolidating here
Status: RESOLVED → REOPENED
Component: Composer → Composition
Ever confirmed: true
Product: SeaMonkey → MailNews Core
Resolution: EXPIRED → ---
Summary: Redesign the toolbar color chip (picker triggers) → Composition: Implement text highlight feature to apply background color to selected text (inline css <span style="background-color:xxx">) / Page background color picker is misplaced
Oh, this bug was for the same problem in HTML Editor component aka "Composer" of SeaMonkey Suite.
I don't know enough how the internals are connected, so moving back to previous product and component.
Bug probably still around as seen from other bugs filed against SM and TB. New summary probably still applies and describes the problem better and more retrievable.
Component: Composition → Composer
Product: MailNews Core → SeaMonkey
Summary: Composition: Implement text highlight feature to apply background color to selected text (inline css <span style="background-color:xxx">) / Page background color picker is misplaced → SM HTML Editor/Composer: Implement text highlight feature to apply background color to selected text (inline css <span style="background-color:xxx">) / Page background color picker is misplaced
Duplicate of this bug: 366671

Comment 31

3 years ago
Only 1 issue per Bug Report, I reduce this one to the inline css - RFE, and for that one we already have "Bug 318600 - Need text highlight feature to apply background color to selected text (inline css <span style="background-color:xxx">) / Page background color picker is misplaced"

For the bad UI we need a different report (may be already one does exist?).
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago3 years ago
Resolution: --- → DUPLICATE
Summary: SM HTML Editor/Composer: Implement text highlight feature to apply background color to selected text (inline css <span style="background-color:xxx">) / Page background color picker is misplaced → HTML Editor/Composer: Implement text highlight feature to apply background color to selected text (inline css <span style="background-color:xxx">)
Duplicate of bug: 318600
You need to log in before you can comment on or make changes to this bug.